Nextcloud and OMV , File sharing windows 10 not working

  • Hello Everyone,


    Since 3 days i dove into openmediavault, i have watched and followed several installation guides. For the moment i have nextcloud and OMV up and running. I just ran into a strange problem to which i havent found any solution.


    I Seem to be unable to access my shared folders through windows 10. So i can see the folders, but i seem not to have permission to access them. Although everything seems to be just fine in the settings in OMV. Privileges are set and ACL is set. I attach screenshots to show my issues.


    My webadmin port is set to 90 because of nextcloud apache server running on 80.
    NO SSL is activated and no certificates are active or used for the moment.Date and time is set correctly
    Here are the screenshots of the different pages. Hopefully someone can see where it goes wrong.


    ACL screenshot.jpgfile system screenshot.jpgusers screenshot.jpgfolders are viewable.jpgprivileges screenshot.jpgsmb shares screenshot.jpgsmb-cifs settings.jpg
    I have spent 3 hours trying, now i give up and going to ask the question. What am i doing wrong??? ;)


    thanks in advance.


    Regards,


    Stephane

  • 1) this has nothing to do with nextcloud, I think (or do you access via WebDAV and not samba)
    2) did it work before setting up nextcloud
    3) what user and pass are you using when accessing the network drive? If windows does not ask for one, map a network drive and manually specify the correct credentials there.

  • Hi,


    Well I didn't test it before installing nextcloud. I set up new omv and directly installed nextcloud.


    Windows ask me the login details for accessing the drive and I am giving the credentials for the user. After that step I can see all the maps but I just can't open them.


    Regards,
    Stephane

  • I just thought of a possible reason it blocks.


    During my installation of nextcloud i issued following commands on the entire drive:
    sudo chown -R www-data:www-data /srv/dev-disk-by-label-Cloud/
    sudo chmod -R 0750 /srv/dev-disk-by-label-Cloud/



    This is to the entire disk, later i changed this to a specific map on the disk. But now i am wondering if these commands could cause the permission refusal throught the samba server on windows 10



    Could this be it?



    And secondly, what would be the reverse commands for it?



    Regards,



    Stephane

  • Well, every Linux user now has access to the whole drive.


    I am not sure what the correct/default access rights are. But it would be better to chown it back (not recursively, so without -R) to the default user and group and chmid it back to 750.


    Greetings,

    Hendrik

  • I had the same issue, until I went to SMB/CIFS > Shares > Nextcloud_data_folder (whatever you named it) > Edit and toggled on Enable permission inheritance. I was able to open the folder from Windows after this point. Even if I toggled it off again, which is weird. But now my issue is that if I create a folder or file in NextCloud, it shows up in my Windows folder. But if I create a folder or file in my Windows folder, it doesn't ever show up in NextCloud. I used Shell in a box to navigate to the folder I created in Windows, so it's there. It's just not being added to the NextCloud database or something. I can't figure this out!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!