Losing link to Plex randomly

  • I've followed a couple of the Techno Dad Life videos to install OMV and set up Plex. For the life of me, I can't get Plex to keep visibility of the folders I've given it access to.

    Here's the steps I've taken:
    1. Installed OMV and OMV-Extras
    2. Installed Docker, snapRAID, and UnionFS from OMV-Extras
    3. Mounted and wiped four hard drives and set them up as a single drive with snapRAID and UnionFS
    4. Created a single top level folder for the drive labeled 'Storage' with access to everyone
    5. Created folders through Windows under 'Storage' for media, etc.
    6. Set up the Plex Docker as described in the Techno Dad Life video
    7. Went back to ACL under Shared Folders to ensure all folders have access to everyone as read/write/execute

    I have to play with these settings over and over and keep relaunching the Plex Docker app and eventually I can see the folders in Plex on my TV or browser. I can successfully watch a movie and all works fine. After a couple days, Plex is no longer able to see the folder for some reason and I've changed nothing. I just let the server run and don't touch it. I can't figure out why it just drops the permissions when I'm doing nothing to it. I was able to go back in and keep resaving settings, rebooting the server, and restarting the Docker Plex app and eventually Plex on the TV would see the movie files again and work correctly. Now, five days later with nothing changing, Plex doesn't see the server again and I can't resolve it this time.

    What does work... I can go through Windows, open the server folder /Storage/media/Movies and play the movie file from there just fine. I'm also able to go into Plex and when adding a folder, see the /Storage/media folder, but unable to see the Movies folder within it.

    This certainly seems like a permission issue, but I can't figure out why OMV just drops permissions to the /Storage/media/Movies folder randomly after it works correctly. Even when going back into Shared Folder settings and confirming that all folders have the same Read/Write/Execute permissions for Owner, Group and Others.

    My initial hope was to start here with OMV and Plex and continue my adventures with Docker and other ways to use my server. Just trying to set up this initial step is proving to be a nightmare and I'm running out of things to try without just throwing this all against the wall, lol. Thanks for any help!

  • Strange.

    I'm gonna go out on a limb and say you're somehow dealing with the docker/unionfs file system issue everyone else is.. Usually this happens at boot, but if your NAS is going to sleep, I guess that could cause it to.

    Basically, docker is starting before the unionfs filesystem is mounted... So it looks empty to Plex, or any other docker... But it works fine with network filesystems (NFS, SMB, etc.)

    Restart your NAS and see if Plex is empty, if so.. ssh your server and restart the docker service (systemctl restart docker). Give it a minute to restart/reload.. then restart the Plex app and see if it's working right.

  • I don't have any problems with dockers and unionfs.

    But I do not use OMV shared folders in Host Paths for docker Volume and Bind mounts. I use fully qualified filesystem paths instead.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Your volume needs to point to /srv/<fuse.mountpoimt>/? as per @gderf suggestion.

    The other volume mounts /home where are these located, if they are on your MergerFS (fuse.mountpoint) they will not work, due to direct_io in the options.

  • @KM0201
    I understand what you're saying. When I restart the NAS, Plex shows that the server is unavailable. When I run the command to restart Docker after OMV is up and running, I'm still not getting access to the movie files. When I go through Plex, I'm able to see the folder for Movies, but Plex isn't able to actually see the movie files anymore (https://i.imgur.com/GdCCkZL.png). There are other folder in the media directory though, such as TV, Music, and Photos that aren't visible for some reason. I've confirmed the permissions under the top level 'Share' folder are set to Read/Write/Execute, have applied all setting to all files and subfolders many times, and have confirmed each folder shows they have the same permissions (https://i.imgur.com/GIL7gaE.png). I feel like I'm taking crazy pills.

    I'm fairly new to Linux as a whole, so I'm having a hard time understanding the /srv/<fuse.mountpoint>/? part. As for the /home directory, it's on my main drive, not the mergerFS drive. I was originally having issues with Plex not wanting to use the mergerFS drive and figured I would try to store on the primary storage drive instead. It seemed to do the trick, but the actual movie files saved on the mergerFS drive just aren't visible. Well, they were, then all of the sudden not anymore after I've changed nothing.

    Thanks again for everyone's help so far!

  • I just went through resaving the ACL rights under Shared Folders and restarting Plex through Docker after running <systemctl restart docker> and watching a few seconds of a movie through Windows and it seems Plex is once again seeing the Movies, along with the TV, Music and Photos folders. Maybe this does have something to do with the drives going to sleep and not spinning back up through Docker apps. Restarting Docker may not have done it, but forcing the drives to spin up watching a movie through Windows may have helped. I'm still not 100% sure what's going on, but I've been in this position twice before now when all of the sudden it may just stop seeing the movies again.

    Is there a topic somewhere else to follow about the docker/unionfs file system issue?

  • I'm fairly new to Linux as a whole, so I'm having a hard time understanding the /srv/<fuse.mountpoint>/?

    Look in Storage -> File Systems under Filesystesystem Type you will see fuse.mergerfs under Mount Point you will see /srv/<fuse-mountpoint> (a line of letters and numbers) it is that you have to use for the Host Path in the container. So it would be;

    Host PathContainer Path
  • What is the issue that could arise with using /home?

    There probably won't be an issue, but the obvious option would be to follow your MergerFS folders, so by having /home/plex as a 'holding' folder just seems logical.
    I use Emby and my transcode, config, metadata folders are under a folder Emby, makes it easier to manage.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!