Raspberry 4 Docker installation

  • Hi all,

    please, I need help. I beg you.

    I own a Raspberrypi 4 with 4GB of RAM and I successfully installed OMV following the Techno Dad Life tutorial.
    Everything worked fine until i decided to do a fresh install again with balenaEtcher since I bought a new 4 TB HDD.

    and oh god... nothing worked anymore.

    1. After I booted the Raspberrypi I can't access GUI no more -> after searching I solved with omv-firstaid, 2 option
    (Why did this happen?! Now I've notice that every time I flash the microSD I have to do this, I can't no longer access the GUI without this step. Is it normal behaviour? Am I missing something? )

    2. I can't install Docker plugin no more -> (last rows)

    Cannot create socket to [localhost]:2812 -- Connection refused
    Errors were encountered while processing:
    >>> *************** Error ***************
    <<< *************************************

    3. I can't use option 1 in omv-firstaid ->

    ERROR: dialog-like terminated due to an error: the dialog-like program exited with status 3 (which was passed to it as the DIALOG_ERROR environment variable). Sometimes, the reason is simply that dialog was given a height or width parameter that is too big for the terminal in use. Its output, with leading and trailing whitespace stripped, was:
    Error: Expected at least 5 tokens for --menu, have 4.

    I read all day long post on how to solve this but didn't find a working solution for me
    I know that there's an issue with DNS but didn't understood well enough and I don't know how to change it
    I tried multiples fresh install but all have the same issue of above
    I tried with commands found on this forum but still didn't solve

    This are my info, can someone please help me?! I am desperate and I don't know what to try anymore...

  • I´m receiving the same error with my RasPi 4 and OMV5. Gonna create a Github Issue.

  • Hi @WastlJ,

    thank you for the reply. What does this mean? is there a bug in OMV?

    Moreover, is there an OMV 5 iso for Raspberry 4? Here I can't find it.

    Lastly, could you please help me solving my problems? ;( Or at least give me some insights of why point 1 happens, if you know.

    Thank you for what you can do!

  • So what is the real problem when you just need to do that ONCE when you have flashed your SD Card?

    Sorry I am not sure I understood the question.

    I don't know why I have to do this step since on the first install everything worked fine. After I've burned the iso to do a fresh install to attach my new 4 TB HDD everytime I burn the iso I must do this passage to be able to get in the Web GUI, but I don't get why if the first time everything worked fine, what has changed?

    But the real problem for me is that Docker doesn't work, the point 1 was just for curiosity.

  • Oh, you need to do Option 2 EVERYTIME you want to login?

    No, i have to do option 2 for every new install. Once I done that I can log in everytime for that installation.
    I am wondering now why the first time I've install OMV I didn't have to do this...

    Thank for referencing me a solution, but I don't know how to apply it (I am very noob).
    If you have time can you kindly help me getting it through please?

  • How often do you new install? If that is only once - where is the problem?

    No problem at all. I was just curios of why on the first installation ever I did not have to do this.

    please give me the output of cat /etc/monit/monitrc


  • please again the output of cat /etc/monit/monitrc

  • then

    cat /etc/monit/monitrc


  • It gives me this error:

    Failed to execute XPath query '/config/services/docker'

    Errore #0:
    OMV\Config\DatabaseException: Failed to execute XPath query '/config/services/docker'. in /usr/share/php/openmediavault/config/database.inc:78
    Stack trace:
    #0 /usr/share/openmediavault/engined/module/docker.inc(31): OMV\Config\Database->get('conf.service.do...')
    #1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModuleDocker->getStatus()
    #2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)
    #6 {main}

    ps. Docker-ce and Docker gui were installed during the comands you told me.
    Should I remove and then reinstall them?

  • I've try to reinstall the docker plugin and I got this error while installing:

  • I solved, you can close the thread, thank you so much for the help so far!!!

    (Don't know how... I just reinstalled for the thousand time and I have done the same steps........)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!