Cannot map shared drives to Windows - I've read the documentation

  • Hi,
    I've read the FAQ and gone through the PDF on connecting to Windows 10, but I can't map any shared folders to Windows.

    I get an error -
    The mapped network drive could not be created because the following error has occurred: A device attached to the system is not functioning.

    I'm using Windows 10, build 18362, OMV4.1.7 on a raspberry pi3 b+

    I have set up a user in OVM with read/write privileges but can't connect.

    I have mounted the disks, created file systems and shared the folders.

    I've been at this for 4 days now and am tearing my hair out, help appreciated.

    Link to some screenshots -

  • This could be anything, but first off turn off Local Master Browser in SMB/CIFS -> Save -> Apply, SSH into OMV and run service wsdd status are you using Ethernet or Wireless, instead of creating a mapped network drive, after checking the above does the Pi appear in File Explorer -> Network

  • Thanks.

    I've turned off the local master browser, ssh'd into the pi and ran the service wsdd status -

    Unit wsdd.service could not be found.

    I'm using a wired connection.

    The host doesn't appear in the network list.

    Thanks for the help.

  • Unit wsdd.service could not be found.

    That's interesting, I assumed that would have been an update for all versions of OMV.

    So in File Explorer -> Network in the address bar highlight network and enter \\raspberrypi.local does that display the shares? or only when you use \\<ip-address of pi>

    From your pictures you have three drives? how many have their own power supply?

  • but they are all plugged into a powered USB hub, which is plugged into the Pi.

    Makes no difference!! The Pi has 4 USB's which use the same chip/bridge as the ethernet, the problem then is almost certainly under voltage. It would probably work with 1 possibly 2 powered drives plugged in 2 USB ports. A powered hub is not a solution.

    One way to test this is to shut down the Pi unplug the 2 non powered drives, plug in the powered drive to a USB port and reboot, the 2 drives removed would just come up as missing in the GUI.

    Have you tried the File Explorer option.

  • Thanks.

    I did what you suggested - the powered drive is plugged directly into the pi, the others disconnected. Same error message when trying to map the drive.

    I am on V4.1.7 (Arrakis).

    If I put \\raspberrypi or \\raspberrypi.local or \\ in File Explorer I just get "this folder is empty"

    If I try mapping a network drive using \\\goflex I get "a device is not functioning" message, if I try just \\ I get "Windows cannot access \\"

    This is in dmesg

    [ 4.652614] brcmfmac: F1 signature read @0x18000000=0x15264345
    [ 4.662682] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 4.663474] usbcore: registered new interface driver brcmfmac
    [ 4.690137] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.txt failed with error -2
    [ 4.793510] scsi 0:0:0:0: Direct-Access Seagate FA GoFlex Desk 0D12 PQ: 0 ANSI: 0
    [ 4.794651] sd 0:0:0:0: [sda] 3907029167 512-byte logical blocks: (2.00 TB/1.82 TiB)
    [ 4.795082] sd 0:0:0:0: [sda] Write Protect is off
    [ 4.795096] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
    [ 4.795633] sd 0:0:0:0: [sda] No Caching mode page found
    [ 4.795656] sd 0:0:0:0: [sda] Assuming drive cache: write through
    [ 4.818821] sd 0:0:0:0: Attached scsi generic sg0 type 0
    [ 4.866427] sda: sda1
    [ 4.869465] sd 0:0:0:0: [sda] Attached SCSI disk
    [ 5.692418] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
    [ 12.918058] random: crng init done
    [ 12.918069] random: 7 urandom warning(s) missed due to ratelimiting
    [ 83.685411] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: user_xattr,usrjquota=aquota.user,,jqfmt=vfsv0,acl
    [ 93.293157] EXT4-fs (sda1): re-mounted. Opts: (null)
    [ 101.980146] EXT4-fs (sda1): re-mounted. Opts: (null)


  • If I put \\raspberrypi or \\raspberrypi.local or \\ in File Explorer I just get "this folder is empty"

    That message makes no sense, this is what I would expect "Windows cannot access \\"

    Ok go back, when you try map network drive and use \\\goflex is goflex an actual SMB share?

  • When it comes to SBC's there are only a few things to go wrong - ranked in order of probability:

    SD-card , first on the list. (Get a new one and a good one, like SANDISK. No generics.)
    Power Problems - for R-PI's it's usually due a long USB cable with thin wires and/or a weak supply. (I didn't see any indication of undervoltage in dmesg)
    Peripheral Hardware (With exceptions for known good chip sets, USB to SATA bridges are suspect.)
    The R-PI itself (Fairly rare.)

    Since there's no knowing the state of your software build, permissions set, etc.; I'd suggest rebuilding in accordance with this -> guide. [Don't get in a hurry and skip the MD5 image checks or testing the SD-card.]
    Use the one drive that has it's own power supply, as a data drive, directly connected to an R-PI USB port - no hub. Build a network share in accordance with the guide, copy a few files into,, and see what happens.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!