OpenVPN stopped working recently

  • My OpenVPN installation on OMV 4.1.23-1 Arrakis stopped working a few weeks ago, and I have tried to troubleshoot by searching through forums and digging through client/server settings. Still not working.

    This evening, I uninstalled and reinstalled, removed and replaced certificates, but I have not made it work.

    My OMV installation is on a Thinkserver TS140, and up to date on OMV 4. I only run NAS for my family, and serve media through PLEX. I maintain a 3-2-1 backup strategy. I use and OpenVPN client on iOS, and through Tunnelblick on MacOS.

    My iOS client suddenly stopped working this summer, and I also noticed that my MacOS client wouldn't connect. I verified that my installation hadn't changed AFAIK.

    I need expertise help, please!

    OMV 4.1.35-1 (Arrakis)
    Lenovo TS140


  • Same Problem.

    After updating i become a tls handshake failed.
    uninstalled and installed new same problem

    I had this problem a few months ago but there was a mistake in the server.conf. now its all fine

  • Hello, I also have a problem with openvpn, looking in the logs it seems that there is a problem accessing the crl.pem file

    root@openmediavault:/etc/openvpn/pki # ll
    total 64K
    drwxr-xr-x 6 root root 4.0K Sep 23 18:24.
    drwxrwxrwx 3 root root 4.0K March 7 2019 ..
    -rw ------- 1 root root 654 Sep 23 18:23 crl.pem

    With these rights I can not connect with a client, if I change the rights it works.

    Someone can confirm :?:

    AMD Ryzen 5 2400G on Asus TUF B450M-PLUS - 8Gb RAM - 3 * 3To RAID5 on LSI Megaraid SAS 9260-8i and 3 SSD in Fractal Design Node 804 Black
    OS: OMV 4.1.26-1

    Edited once, last by Methy ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!