Testing OMV 5.5-1

  • Hi
    I'm testing OMV5.5-1 on a test PC. What's the best way to install OMV-Extras without breaking the apply button?
    Testing PC is an amd64 dual core with ssd for OS. Installed Debian Buster than I followed guide. Works great so far.

  • I'm actually reinstalling in vbox at the moment, but my test box is running well (although there was some issues with getting OMV-extras installed).


    I'll post back in a minute.

  • Ok I've been installing and testing since 5.0 and trying omv-extras the plugins work, the update and upgrade work but the apply button on the webgui errors out. I've seen this problem on the forums I was wondering what the fix was.

  • I've not had issues with the apply button on my test build, my issue was getting omv-extras installed period. Once it was installed, it worked fine. What browser are you using? Are you using English for the webUI language?


    https://forum.openmediavault.o…?postID=211177#post211177


    I eventually got it installed by manually adding the repo, key, etc. Just checking the virtual install I just did, it's not been fixed yet. They're aware of the problem so I'm sure it will get figured out shortly.

  • I downloaded openmediavault-omvextrasorg_5.0.2_all.deb and got an OMV\Rpc\Exception: Invalid RPC response using the webgui I than used dpkg -i openmediavault-omvextrasorg_5.0.2_all.deb which worked. the plugin where available but the apply button stopped working.


    I'm using firefox with english webgui.

  • dpkg probably didn't work... There's an issue with the path settings in the deb file.


    cd /etc/apt/sources.list.d and see if you have omvextras.list.... if it's not there, it didn't work (although just watching the terminal, it looks like it did)


    I've had zero issues with the apply button. Try holding Control and clicking the refresh button while on your webUI, to clear the browser cache... maybe it installed and there's just a cache issue.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • If you can't get omv extras to install... Some in another thread said it installed fine for them... I'm not sure how, as I've had to do this same procedure on 3 virtual machines and on the test build I'm using..


    SSH your server and become root.
    apt install gnupg2
    touch /etc/apt/sources.list.d/extras.list
    nano /etc/apt/sources.list.d/extras.list
    Add this line: deb hxxps://dl.bintray.com/openmediavault-plugin-developers/usul buster main (note that should be https at the beginning, I altered it so it would not post as a link and you could copy/paste it)
    Cntrl X, then Y to save, and you should be back at the prompt
    Add the apt key for omv-extras: apt-key adv --keyserver keyserver.ubuntu.com --recv EDEE7D73
    apt update
    apt install openmediavault-omvextrasorg
    apt update (you should get a bunch of errors about duplicate sources lists)
    Remove the source list you created, this will leave the omvextras.list that the plugin creates. rm /etc/apt/sources.list.d/extras.list
    apt update and all errors should be gone.
    Log in to the webUI and reresh, and you should see omv-extras in the sidebar.

  • hi
    I used dpkg -i openmediavault-omvextrasorg_5.0.2_all.deb than omv-update. In source.list.d omvextras.list is installed with inside



    deb https://dl.bintray.com/openmediavault-plugin-developers/usul buster main
    deb https://apt.syncthing.net/ syncthing release
    deb https://download.docker.com/linux/debian buster stable
    deb http://linux.teamviewer.com/deb stable main



    I installed flash memory and reset permission plugins. Did small change to test apply button and it works!!!!
    I've read about the problem with the back ports. I hope that's fixed. My main PC is a media server with OMV 4 which has been running for a year. I'm very happy with it. I'll probably switch over to OMV 5 in the new year, no rush.
    Thanks for your help


    P.S. Next learning project is OMV5 on RPI3. I've four of them.

  • got an OMV\Rpc\Exception: Invalid RPC response using the webgui

    This is a bug in OMV not omv-extras. It has been fixed but not released yet. Using the command line should work fine.

    I've read about the problem with the back ports.

    That is only an issue if you clicked the apt clean button. I have fixed that and put 5.0.3 in the repo.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!