Can't figure out SSH PKA

  • Hi all,


    I've got SSH up and running and was able to connect with a password. Right now I would love to disable password authentication for better security.


    I followed the steps of this and this guide, but when I disable password authentication I always get the same error:


    Code
    C:\Users\myuser>ssh myuser@192.168.1.2
    myuser@192.168.1.2: Permission denied (publickey).
    C:\Users\myuser>ssh 192.168.1.2
    192.168.1.2: Permission denied (publickey).

    I'v tried on Windows 10 with the native ssh and I've tried on WSL and both got the same result.


    I'm not sure how to debug this since I literally just followed the steps. I've also added myuser to the ssh group. I have disabled the "user home directory" option via the web interface, could that be an issue?


    Thanks!


    EDIT: Sorry for placing this in the wrong thread.

  • Check the permissions of the root directory on your NAS with ls.


    If it's 777 (rwxrwxrwx) it needs to be changed to 755, which you can do with:


    Code
    chmod 755 /


    I had the same issue with SSH PKA not working when password authentication is disabled. The log on OMV provides a clue with SSH giving an error and refusing to continue due to permissions being too permissive.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!