Transmission shared folder problem...

  • Hello everyone. Before I post here, I have spend some time searching and I have tried a few thinkgs but now I have hit a wall...

    - I've successfully installed the latest OMV in my raspberry pi.
    - created a user with admin rights
    - creared shared folders on an NTFS formated hard drive.
    - Installed transmission plugin.

    Now when I try to start the Transmission client, I have to go first to "files and locations" tab and setup a shared folder and that's where my problem is. No matter what I do... ( I have also tried what is advised on this guide but no luck)

    [GUIDE] Configuring and using Transmission plugin for permissions

    I get something like this error.

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf transmissionbt 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/transmissionbt: 60: local: 2TB: bad variable name

    Error #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf transmissionbt 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/transmissionbt: 60: local: 2TB: bad variable name in /usr/share/php/openmediavault/system/ trace:#0 /usr/share/openmediavault/engined/module/ OMV\System\Process->execute()#1 /usr/share/openmediavault/engined/rpc/ OMV\Engined\Module\TransmissionBt->applyConfig()#2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#3 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#5 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusfF...', '/tmp/bgoutputfQ...')#6 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#7 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#9 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)#10 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#11 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#12 {main}

    Can you please help me with this problem?

    Thank you very much for your time

  • Thank you for your reply. The HDDs I have are inside a 5 HDD dock which are all formated in NTFS and have files in them. I've used OMV for the last 2 years now and I had no problems with it. This problem appeared now because I tried to make a clean start and use the latest version.

    Before OMV I used a Buffalo NAS as a torrent station and I had big problems with its file system everytime I had a crash. So I decided that I've had enough with non windows filesystems. I want to be able to plug the USB anytime I want to a windows machine and make changes...

    So I l know it is possible with OMV to use NTFS file system. I've had this setup for 2 years now! However, I've had a little trouble in the setup process as well back then, but I can't remember what I did in order to fix it...

    My question Is... Is it still possible to use this setup as it is or OMV has changed in a way that I can't...?

  • Hi again. I tried to use the "Dockers" method mentioned in this youtube video:

    but as soon as I select to install Docker, the procedure starts and after a while I end up with 100s of lines like this:


    <<< *************************************

    >>> *************** Error ***************

    <<< *************************************

    and I can't even copy/paste or even see the actual error because as soon as I scroll up, the page keeps refreshing every second and it takes me automatically to the bottom!

  • OMG!!!! I AM ABOUT TO COMMIT SUICIDE! I've spend 5 days searching and trying things... Teamviewred my home PC from work... I flashed the sd more than 15 times (I'm serious here!), tested so many different things, missed the gym twice... and you know what the problem was in the end?! THE DISK LABEL! The disc label was something like "1. WDRED - 2TB". As soon as I deleted that and left it without a label, the thing worked! Right now I can't decide if I'm happy or depressed!

  • Hello! Thanks for your reply! It is the latest version at this time... 4.1.7 (Arrakis) and I'm using it on a Raspberry Pi 3 model B+. Now everything works ok, appart from one little problem...

    If I perform reset, Transmission apeaps to start before the system completely mounts the shares and it gives an error (file location not found). I've Googled around a bit and found that I should add a sleep 60 line to /etc/init.d/transmission-daemon which I did but it still starts too early (command doesn't work)...

    Is there a way to achieve a delay in starting the script?

  • seems problematic the label, the webui doesn't allow spaces in disk formatting. Anyway this won't get fixed, people using this should migrate to docker in omv5

    The delay problem, shouldn't be like that, but since is a rpi3 don't expect much from them. You should maybe override the systemd transmission unit and add a in the [Unit] section

  • Thank you very much for your help! :) I'm really sorry but I'm not very good with Linux systems... If it is not too much trouble, could you please give some more details in how to do that?

    Also I understand that a RPi3 is not the best solution... However it makes for a good, cheap, low cost, low maintenance, low power, low noise and reusable (hardware-wise) torrent station :) I mainly need to solve this small problem at the moment and I'll be happy with my life :D

    Edit: ok, after looking around, I went and used nano for the file /etc/systemd/system/ and did as you said... I have added a in the [Unit] section. The problem remains... :( I can see the HDDs getting mounted and at the same I'm able to log into transmission. :(

    Edit 2 (12:46 am) :P : Ok, I understand how unelegant and probably silly this way is, but again after looking around, I did this change at the [Service] section of transmission-daemon.service...

    ExecStartPre=/bin/sleep 40
    ExecStart=/usr/bin/transmission-daemon -f --log-error

    at least now it works and loads everything after a reboot! I wouldn't be able to do that without your help! Thank you very much! However if there is still another nicer way of doing this, please let me know... But at least for now everything works in harmony... :)

  • Maybe should've been Requires= instead of wants, also with add If that solution works for you should be ok.

    I tried but it doen't appear to work... :(

    What do you mean "...with add"? I mean where and how I should put that?

  • Not sure if it will work, came out of my mind didn't test it

    Maybe add a dependency to the mount point srv-dev\x2ddisk\x2dby\x2dlabel\x2dtest.mount

    You can find the unit name to the mount point looking in /var/run/systemd/generator

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!