Shared Folders

  • When I create a folder with Shared Folderes I get the following error:
    ( I tried to solve it like this thread Samba ) but the problem persists.

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run systemd 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/modules/ DeprecationWarning: Using or importing the ABCs from 'collections' instead of from '' is deprecated, and in 3.8 it will stop working from collections import Iterable, Mapping/usr/lib/python3/dist-packages/salt/utils/decorators/ DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function)/usr/lib/python3/dist-packages/salt/utils/decorators/ DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function)debian:---------- ID: remove_sharedfolder_mount_unit_files Function: Result: True Comment: file.find: ['/etc/systemd/system/sharedfolders-Dockerapp.mount', '/etc/systemd/system/sharedfolders-docker.mount'] Started: 18:59:50.027245 Duration: 1.622 ms Changes: ---------- file.find: - /etc/systemd/system/sharedfolders-Dockerapp.mount - /etc/systemd/system/sharedfolders-docker.mount---------- ID: configure_sharedfolder_docker_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-docker.mount Result: True Comment: File /etc/systemd/system/sharedfolders-docker.mount updated Started: 18:59:50.029873 Duration: 1.729 ms Changes: ---------- diff: New file mode: 0644---------- ID: configure_sharedfolder_Dockerapp_mount_unit_file Function: file.managed Name: /etc/systemd/system/sharedfolders-Dockerapp.mount Result: True Comment: File /etc/systemd/system/sharedfolders-Dockerapp.mount updated Started: 18:59:50.031670 Duration: 1.328 ms Changes: ---------- diff: New file mode: 0644---------- ID: sharedfolder_mount_units_systemctl_daemon_reload Function: Name: service.systemctl_reload Result: True Comment: Started: 18:59:50.033066 Duration: 0.205 ms Changes:---------- ID: enable_sharedfolder_docker_mount_unit Function: service.enabled Name: sharedfolders-docker.mount Result: True Comment: Service sharedfolders-docker.mount is already enabled, and is in the desired state Started: 18:59:50.435947 Duration: 136.757 ms Changes:---------- ID: restart_sharedfolder_docker_mount_unit Function: Result: False Comment: An exception occurred in this state: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/salt/", line 1919, in call **cdata['kwargs']) File "/usr/lib/python3/dist-packages/salt/", line 1918, in wrapper return f(*args, **kwargs) File "/usr/lib/python3/dist-packages/salt/utils/decorators/", line 558, in _decorate return self._call_function(kwargs) File "/usr/lib/python3/dist-packages/salt/utils/decorators/", line 263, in _call_function raise error File "/usr/lib/python3/dist-packages/salt/utils/decorators/", line 250, in _call_function return self._function(*args, **kwargs) File "/usr/lib/python3/dist-packages/salt/states/", line 294, in run func_args=kwargs.get(func)) File "/usr/lib/python3/dist-packages/salt/states/", line 358, in _call_function mret = __salt__[name](*arg_type, **func_kw) File "/usr/lib/python3/dist-packages/salt/modules/", line 906, in restart raise CommandExecutionError(_strip_scope(ret['stderr'])) salt.exceptions.CommandExecutionError: Job for sharedfolders-docker.mount failed. See "systemctl status sharedfolders-docker.mount" and "journalctl -xe" for details. Started: 18:59:50.572945 Duration: 19.002 ms Changes:---------- ID: enable_sharedfolder_Dockerapp_mount_unit Function: service.enabled Name: sharedfolders-Dockerapp.mount Result: True Comment: Service sharedfolders-Dockerapp.mount is already enabled, and is in the desired state Started: 18:59:50.592206 Duration: 15.794 ms Changes:---------- ID: restart_sharedfolder_Dockerapp_mount_unit Function: Result: True Comment: service.restart: True Started: 18:59:50.608247 Duration: 41.641 ms Changes: ---------- service.restart: True---------- ID: configure_tmp_mount_unit_file Function: file.managed Name: /etc/systemd/system/tmp.mount Result: True Comment: File /etc/systemd/system/tmp.mount is in the correct state Started: 18:59:50.650123 Duration: 14.177 ms Changes:---------- ID: tmp_mount_unit_systemctl_daemon_reload Function: Name: service.systemctl_reload Result: True Comment: State was not run because none of the onchanges reqs changed Started: 18:59:50.664675 Duration: 0.003 ms Changes:Summary for debian------------Succeeded: 9 (changed=4)Failed: 1------------Total states run: 10Total run time: 232.258 ms

  • If you check your log carefylly, you will find following:

    Try to run "systemctl status sharedfolders-docker.mount" and check why it failed.
    For additional information you can also check "journalctl -xe", but make sure you read the log at exactly the time the error occurred.

  • This is what come up with

    systemctl status sharedfolders-docker.mount

    ● sharedfolders-docker.mount - Mount shared folder docker to /sharedfolders/docker Loaded: loaded (/etc/systemd/system/sharedfolders-docker.mount; enabled; vendor preset: enabled) Active: active (mounted) since Sat 2019-08-31 08:32:28 CEST; 46s ago Where: /sharedfolders/docker What: /dev/sda4 Tasks: 0 (limit: 4915) Memory: 120.0K CGroup: /system.slice/sharedfolders-docker.mount

    I tried to create folders in sharedfolders, the folders are created but I can confirm them with the error indicated above. And at the same time I can't delete the folders created under Sharedfolders. I have no active Samba, the home is disabled.

  • Ok I reinstalled everything and everything seemed ok, without errors in creating folders in sharedfolders, but when I installed Docker-porttainer, the problems started again as above, then I uninstalled docker and everything started to work well

    • Official Post

    The mount can't be restarted when it is in use. If it isn't restarted, it might not get changes.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8 plugins source code and issue tracker - github - changelogs

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Unfortunately I can't answer you, after 2 days of attempts I had to give up and install the OMV4, now I have no problem. I knew that OMV5 is in Beta, I will wait for the official stable version.

  • Even if I am not an expert but a simple user, I came to the conclusion that the problem is caused by an incompatibility of the Filesystem Union or mergerfs plugin. All my problems come up (because even with Omv4 I start having the same problems) when I start using this plugin. I wanted to avoid using Raid5 or Zfs1 but I think I have no other way. I read somewhere that the problem is caused by Systemd.

  • As you write above your problem is related to this thread: MergerFS folders not mounted in /sharedfolders
    @votdev has posted a possible permanent solution a short time ago. Maybe you want to support him?

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!