[SOLVED-AGAIN!] Airsonic 502 Bad Gateway error

  • I install airsonic in docker. Receiving 502 Bad Gateway error. I am trying to use reverse proxy and letsencrypt to access airsonic from internet. Any help, please?


    This is my airsonic.subfolder.conf, which, I'm sure, is wrong



    And my docker configuration


    1.png2.png3.png

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

  • join airsonic in the network of the docker container an try this conf

  • join airsonic in the network of the docker container an try this conf


    It's working! Thank you!


    EDIT 19. 01. 2020


    @Morlan


    I am on OMV 5 now, and this don't work anymore. :-(


    I am landed on nginx wellcome page

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

    Edited 2 times, last by gett ().

  • Did anything else change? Are airsonic and letsencrypt connected in a docker network? Does your airsonic container have the name airsonic?

    1. No, to the best of my knowledge
    2. Yes, I add Airsonic in nextcloud/letsencrypt yml
    3. Yes


    This is my airsonic.subdomain.conf




    I have to make some general mistake. All my containers (except nextcloud) land at nginx welcome page when I join them to nextcloud network

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

  • I just saw that airsonic's web gui runs on port 4040.

    Don't work. Never mind, I deleted airsonic. Thank you for your help and time. I will look for another audio streamer.
    Or maybe start all thing from scratch.
    :)

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

  • Or maybe start all thing from scratch.


    OK, works now.


    Solution is silly. I start from scratch, Portainer and OMV 5.x
    All as usual, exept I call airsonic not from https://mydomain.com/airsonic, but from https://mydomain.com:4040/airsonic.
    Works like a charm. ?(


    Edited: This is true for local LAN: LOCALIP:4040/airsonic. For outside access I stil use MYDOMAIN/airsonic

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

    Edited 2 times, last by gett ().

  • Did you forward port 4040 on your router?

    No. I joined airsonic to my nextcloud network. forwarded are just 443 and 80, like in @macom guide.
    The thing is, when I access Aircloud from my local LAN, I am using LOCAL IP:port/airsonic thing, This morning discovered that from outside networks I have to use MYDOMAIN/airsonic, w/o port. I don't understand why, but it's working. Nginx conf in letsencrypt is enabled w/o any edits.


    And airsonic container is joined to Bridge AND nextcloud network in docker.

    = Fujitsu PRIMERGY TX1310 M3 • 2 x HDD 3.5" 4TB Western Digital Red • Windows Server 2019 • Hyper-V • OMV 5.x =

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!