urBackup wrong backup storage path (to the SD card)

  • Hi guys.
    On my omv I've enabled urBackup service. On my W10 machine i've installed urBackup client. I've started full image backup and got error about not enough space to finish this process.
    Why backup storage path is linkin to SD card? How to change this and how to delete image from SD card?

    • Official Post

    I'm guessing that you're using OMV4.

    The default storage location is to the boot drive. This -> post will show you where to look (in UrbackUp) and how to move the client backup storage location. And there is other info, in the thread, that may be of interest.

    The same UrbackUp screen, above, will show where the current directory on the boot drive is located. You'll have to manually delete any backups in this location. (You could do this, in Urbackup, before you change the storage location.)
    I would follow up and delete the urbackup directory from the boot drive as well.

  • Thank you crashtest.
    It's OMV4.
    I really put new backup storage path before trying to do new backup, but missing /sharedfolders/media/...
    Now I can't start web interface of urbackup: ERR_CONNECTION_REFUSED
    Probably I have to delete or move more files from SD card.
    What I did:
    mv /var/urbackup /sharedfolders/media
    mv /var/backups /sharedfolders/media

    My SD card is still full of data and I guess that is the reason why there is no access to urbackup via www and docker is no working. I have to learn more linux command...

    Any suggestion what to delete/move from mmcblk1p2?

    cd /var
    cache folder2ram lib local lock log log.hdd mail opt run spool swap tmp www


    • Official Post

    A symptom of a packed boot drive is being denied access to the GUI.
    You might be able to get into the GUI for Urbackup - yourserverip:55414 (I don't know. I've never tired it with a full boot drive. If it allows you in, you could delete backups from the GUI.

    If you're not sure of the command line, have you looked at WinSCP? Install it on a Windows machine and use the servers IP address, root + password, to access your server. A few more details on WinSCP are in this -> guide, page 58.

    I wouldn't try to move backup files, just delete them. Urbackup will automatically run new backups in any case. ((Thinking about that, you might want to keep the Windows client off while you're clearing out these files. If a new backup kicks off, it doesn't take much to refill the SD-card.))

    In selecting your storage location, note that the path to data disks in OMV4 starts with /srv/ , then the data disks label name, followed by the folder on the data drive. So, your Urbackup storage location on a data drive should look something like this:

    If you navigate to the location where you want to store client backup files, using WinSCP, you could copy the line in WinSCP's address bar and paste it into Urbackup. Don't forget to add a sub-dir and set permissions according to the post.

  • Thanks a lot, crashtest.
    SD card OK.
    WinSCP was very usefull because it was not possible to start urbackup' web gui. Also NAS was not visible in a Windows 10 under "network".
    Tommorow will try to add permission to folders. Today WinSCP stop to work (server connection closed). Also shellinabox don't work (session closed after typing login).
    Too many problems for one day :) need some break.

    • Official Post

    Just to get a clean start, you might think about rebuilding. If you do, backup your boot SD-card with the cloning process that's in the guide (under OS backup). With a clean clone, if something goes wrong, you'll have the ability to back out of the problem.

    Also, the guide has info on PuTTY, an SSH client that installs on a Windows client like WinSCP. When you can't get into the GUI, PuTTY is far better than Shell In A Box. :)

  • Tried putty yesterday, not working. It looks like ssh is disabled, but it's enabled.
    Shellinabox, putty, WinSCP and also terminal in omv web gui - all not working.
    Not sure, maybe I broken something by chmod when trying to delete files from sd card?

    Rebuilding is a good idea, who knows how many things I broken? :)

    • Official Post

    Rebuilding is a good idea, who knows how many things I broken?

    I'm real sorry to hear about that but, "it" happens. If you got WinSCP to work before, for deleting Urbackup files, root login's must be enabled so I'm out of ideas here. If you can't get on the command line that's, pretty much, "it".

    But, your data is still on your data drive. When setting up shared folders again, all you'll have to do is navigate to the old share locations using the folder icon. Your data will be there.

    The second time around, get a second SD-card and once your configuration is restored make sure you have OS backup. It's pretty easy to do.

    With OS backup, you'll have some freedom to experiment.
    I will say that being careful when working on the boot drive is a good idea. Utilities like WinSCP, PuTTY and others are powerful and, generally, they don't have warning dialogs. This is part of the reason why it's good to get data storage off of the boot drive.
    (BTW: using chmod anywhere on the boot drive, without knowing the effects, is not such a good idea.)

    • Official Post

    Tried putty yesterday, not working. It looks like ssh is disabled, but it's enabled.

    Login as root via ssh is disabled on SBC. You have to use another user that is member of the SSH and sudo group or enable root login in the GUI of OMV.

  • Hi macom.
    It's not this case. Session closed after typing login + Enter. My root account was working via ssh. Tried also other account, no success.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!