haugene/transmission-openvpn: Transmission not available after opening vpn connection

  • Hi all,

    I am new with OpenMediaVault and I am following the tutorials from Techno Dad Life.
    Now i was following the "How to Install Transmission with VPN on Openmediavault 2019" tutorial, but I have a issue and i can't find the solution.

    If I start the container and go directly to <ip omv>:9091, the Transmission GUI is showed.
    If i hit F5 the page reloads until the VPN connection is established, than i loose the connection with Transmission.
    I have tried many things with the network settings, but I cannot get it working.

    What do i wrong?

    Raspberry Pi 4
    Used OMV image: OMV_4_Raspberry_Pi_2_3_3Plus_4.img.xz (4.1.23-1 Arrakis)

    Docker Engine - Community
    Version: 19.03.2
    API version: 1.40

    First i create mynet network
    docker network create mynet

    After that i start the container, and when the VPN connection comes up the transmission webpage is not reachable anymore

    Even when I do it through the OMV GUI I have the same problems

    The container log file:

  • I found something out.
    If the container is running and the VPN connection is up i lose the connection.
    If i run a cmd in the docker container "ip r" i see all routes via dev tun0
    default via dev eth0 via dev eth0 dev tun0 proto kernel scope link src via dev tun0 dev eth0 proto kernel scope link src via dev eth0

    if i remove via dev tun0 by run ip route del via dev tun0 the web interface from Transmission comes back!

    If i check the traffic in the container it is still using the VPN connection.
    curl ifconfig.co returns the WAN IP of the VPN connection.
    If i run the same command on the Raspberry Pi I get my own WAN IP, everything looks good sofar.

    But how can i fix the issue without having remove the route manually?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!