Backing up USB Installation

  • Is there a way to make this work, or should I just scrap the current USB and install on one of the new ones?

    Win32diskimager will clone larger SD-cards to smaller cards if the "Read only Allocated Partitions" box is checked. This previously mentioned cloning process is in this -> guide under OS backup.

  • There is a setting in Clonezilla to allow cloning a larger drive to a smaller drive.

    the setting is called -icds
    It is used to enable/disable checking the size of the target drive before starting the clone process. Worked always for me, but others had issue with it.

  • Quote from macom


    the setting is called -icds
    It is used to enable/disable checking the size of the target drive
    before starting the clone process. Worked always for me, but others had
    issue with it.

    Thank you. This worked for me. I was able to make two copies of the os and then changed the settings for the USB plugin.


    I am almost ready to seperate the two drives in the raid1. I was going to do one more rsync, but it seems the brand new Seagate drive I was backing up to has died. The disk turns on, but there is no light and the computer doesn't see it anymore. I may have one more drive that will work.

  • There isn't, none that I know of, you would need to rsync your files to the external, then break apart the array (this can be done in the gui) wipe both drives and start again. To begin, rsync back to one drive and set up your shares as the folder structure will be in place on the drive, then rsync to the second drive. Then set up a scheduled job for rsync from drive 1 to drive 2 in after hours, until it's all reset and running leave the usb alone at least you know you have a backup.

    I am not seeing a way to break apart the raid. Do I just remove the raid or is there specific separate option? Or remove one of the disks for raid, wipe it, create new file system, and then remove the raid and then do the same with it and then use rsync between the two?

  • I removed one of the drives from the raid, reformatted it and restored data to it. When I go back to Raid however, I am unable to remove or delete it. Can I just wipe it under discs and then create a new file system for it. Once this is done will it disappear from Raid?

  • Can I just wipe it under discs and then create a new file system for it.

    The raid should be showing as clean/degraded, to remove the last drive and the array, delete SMB shares associated to the raid, delete any shared folders associated with the array, it must be done in that order, SMB -> Shared Folders then you can delete the array.

  • I deleted all SMB shares and then all associated folders. Its still not allowing me to delete the array in raid.


    I figured it out. I needed to unmount the raid in the File System and then I was able to delete it.


    Thank you for your help. Now to setup Rsync.


  • You're right line 5 should not be there and you can delete it, just wanted to make sure.

    So, it looks like I did this again. I got a new external USB drive and created a new backup job. Unfortunately, the drive wasn't remounted after creating the filesystem. Once again several Gigs of data were added to the system drive. Only this time, I can't figure out where. Last time it showed up in the main folder (/) as dev-disk-by-label-Raid1. This time nothing like that is showing up. Is there another place the files might have been put?


  • The backup works once I got the file mounted. I have attached a screen shot. The job is: rsync -av --delete /srv/dev-disk-by-label-System/ /srv/dev-disk-by-label-5gbUSBbackup/


    Here is the file system for srv



    Code
    drwxr-xr-x 10 root root 4096 Sep 6 13:00 dev-disk-by-id-usb-Seagate_Ultra_Slim_MT_NA95j42B-0-0part1
    drwxr-xr-x 11 root root 4096 Sep 21 17:31 dev-disk-by-label-5gbUSBbackup
    drwxr-xr-x 11 root root 4096 Sep 21 17:31 dev-disk-by-label-Backup1
    drwxr-xr-x 11 root root 4096 Sep 21 17:31 dev-disk-by-label-System
    drwx------ 2 root root 4096 Sep 30 11:26 dev-disk-by-label-USBbackup
    drwxr-xr-x 2 ftp nogroup 4096 Sep 4 18:02 ftp
  • After doing a full backup with that drive and then unmounting it, the extra data seems to be gone. I am now at 6bg of OS drive.


    This following file, listed in srv is no longer needed...I don't think. The drive failed and has been thrown away. It isn't attached to the system and doesn't show up in file system anymore. Can this file also be deleted? It's showing about 1.1GB of data.


    dev-disk-by-id-usb-Seagate_Ultra_Slim_MT_NA95j42B-0-0part1

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!