Issues with Mount a WD 4tb My Passport HDD and with install PlugIns.

  • Hi Team!


    I'm playing with OMV 5.0.5 ona Beelink MiniPC (Nuk type) with 8gb of RAM and booting the system from a USB 3.0 32Gb Stick, also, with an internal 2.5HDD and 2 external thru USB 3.0.
    I have some issues and I had to reinstall all 3 or 4 times. (I will start the 5th early)


    Now, All seems to be fine, I can access to the shared folders and also I installed a Portainer with Transmission without problems.
    But (the fatal "But") when I plug the second HDD via USB, and I tried to mount, the system returned an ERROR:



    I tried with other external HDD and it works properly, also I checked this HDD in other machine, and all the data is accessible.
    As I can understand, it is like the HDD is already mounted and the system is not able to mount again. ¿?



    As the same time, other issue appears, I'm not able to add plugins, I solved this issue before (in one of the other installations of OMV5) with a new installation.





    I think that something was corrupted when I plugged the HDD, and may be it will be easy to restore the stability of the system, but my knowledge is not enough.




    One more point of information: I have in a externar board, Orange Pi Zero, a Pi-Hole system running, and I saw that sometimes I have to disable it to perform some actions, as for example to be able to install the OMV-Extras.




    At the moment, I only publish this post just for share with you and may be some one is able to find an easy solution.




    But don't break your brain at the moment, because I will do a new installation again and any new comment about to type a code line or something will not be done at this point (instead If I will find the same problem again, then, I will update you with all the process).




    Thanks for your time.

  • Can you please post the output of


    Code
    $ ls -alh /dev/disk/*


    after the USB-HDD has been plugged in?

    Hi @votdev,


    I installed again all the system, but the issue is there. May be something wrong with the HDD?? But I can work with him under Windows 10 with no problems.


    Here you have the answer from the system:



    Thanks for your time

  • @votdev, here the info:


    Code
    /dev/sda1: LABEL="750Gb" UUID="00700B67700B62B0" TYPE="ntfs" PARTUUID="96419641-01"
    /dev/mmcblk1p1: LABEL="Extras" UUID="76d48057-9c8d-40dc-a92b-1888bd81793d" TYPE="ext4" PARTUUID="77b7662b-98d8-415f-b7ea-b4893a7f38e9"
    /dev/sdb1: LABEL="3Tb" UUID="383C8D5A3C8D13D2" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="14839bd2-b743-46c2-b6e5-7ef7a9d9cc69"
    /dev/sdc1: UUID="b4d0e3d6-9b51-4b0d-bc3a-f1be6a6b820e" TYPE="ext4" PARTUUID="7a236ad2-01"
    /dev/sdc5: UUID="5cce6762-3298-4792-842c-722c19690fb5" TYPE="swap" PARTUUID="7a236ad2-05"
    /dev/sdd1: LABEL="My Passport Blue" UUID="20E87DF9E87DCE12" TYPE="ntfs" PTTYPE="atari" PARTLABEL="My Passport" PARTUUID="eb1e1bfc-b406-4191-8a95-546bb457bbb1"
    /dev/mmcblk1: PTUUID="2d55a785-f8ab-45f3-aa9d-ee8c8acd28c3" PTTYPE="gpt"
  • Meanwhile some one will have any idea, I tried with OMV4, and result that my miniPC is nos compatible.
    The Ethernet board doesn't work, and thru Wireless I can't connect.
    Then I will come back to OMV5.


    X/

  • Hi @votdev


    Well, more "bad News" .


    I came back to OMV5.


    I have another WD My Passport 4tb.


    Appears the same error message when I want to mount the HDD. (I will change also the title of this thread)


    Maybe is a incompatibility with this model of HDD?


    Thanks in advance.

  • Hi again @votdev,


    Last test that I can do it today:


    I installed OMV5 in another machine, where I has before OMV4 (Old Intel i7 Laptop with overheat issues).


    The issue is the same, something happens with the Western Digital My Passport 4Tb Hard Disk.


    - Who is the "bad guy"?: The Brand, The capacity The HDD Firmware, OMV5?


    This Model of Hard Disk was working properly with OMV4, tomorrow I will came back to OMV4 with the i7 to be sure.


    Error:



    Diff
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run fstab 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/modules/file.py:32: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working from collections import Iterable, Mapping /usr/lib/python3/dist-packages/salt/utils/decorators/signature.py:31: DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function) debian: ---------- ID: create_filesystem_mountpoint_569103a0-b8a2-4d52-a9c2-20ec97a74a25 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_569103a0-b8a2-4d52-a9c2-20ec97a74a25 for file /etc/fstab was charged by text Started: 01:22:38.550194 Duration: 0.579 ms Changes: ---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: Changes were made Started: 01:22:38.551201 Duration: 3.312 ms Changes: ---------- diff: --- +++ @@ -10,3 +10,6 @@ # swap was on /dev/sdb5 during installation UUID=334aca66-d074-476a-a100-a6858974b3cc none swap sw 0 0 /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0 +# >>> [openmediavault] +/dev/disk/by-label/My Passport Blue /srv/dev-disk-by-label-My Passport Blue ntfs defaults,nofail 0 2 +# <<< [openmediavault] ---------- ID: mount_no_bind_mountpoint_569103a0-b8a2-4d52-a9c2-20ec97a74a25 Function: mount.mounted Name: /srv/dev-disk-by-label-My Passport Blue Result: False Comment: mount: bad usage Try 'mount --help' for more information. Started: 01:22:38.555041 Duration: 362.689 ms Changes: Summary for debian ------------ Succeeded: 2 (changed=1) Failed: 1 ------------ Total states run: 3 Total run time: 366.580 ms


    More Details:



  • It seems to be that SaltStack can not handle blanks in device names and mount dirs properly. Need to find a workaround and maybe a bug fix for the upstream project.


    I really can’t understand why it is necessary to use blanks in filesystem labels or file names. As SaltStack has it’s problems with it i think blanks in filenames are not widely used in Linux and it seems to me that this absurdity comes from the Windows world.

  • I really can’t understand why it is necessary to use blanks in filesystem labels or file names.

    Probably it is not necessary, but people do it if they are not aware it will cause problems. So maybe an error message when creating the label would help. At least in those cases where the label is added using OMV.

  • The OMV UI does not allow blanks in filesystem labels since ages.

    With OMV4, I was able to work with this HDD, also with blanks, for this reason I was worried when with OMV 5 I was not able to mount the HDD, I supposed also that the the HDD was damaged.. .

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!