Trying to create a separate share with different credentials

  • Hi
    I've been struggling to get this to work:
    I have omv 4 on my rock 64 with 2 smb shares on 2 external hard drives, everything is working nicely...


    now I want to have a 3rd share on one of my drives and I want it to use a different username & password...
    I failed to get this to work...
    at first I created a new user and share, gave user permissions and tried to connect, windows complains I can't use 2 credentials to the same server...
    fine, tried IP, now I get this:


    and NOTHING I tried works!
    things I tried:
    editing ACL's
    resetting ACL's
    inheriting them...
    turning on gusset access in smb
    tweaking ACL's via winscp
    deleting and recreating the share and user... multiple times
    deleting windows net use
    deleting credential cache in windows control panel
    rebooting
    screaming / crying :S;(:cursing:


    same result...please help!


    thank you.

  • Another annoying thing:
    I just created an omv vm in hyper-v and basically did pretty much the same steps...
    and it worked!

    so I AM doing everything right!
    bug in the arm version?




    OK!
    Mystery Solved!


    I played around and created a share on my other drive and everything worked
    then I turned off the device and plugged my 2 drives into a linux machine ....


    I noticed something was off with the permissions on the problematic drive
    I couldn't create files in the new folder for the share and there was a little lock overlay icon in Ubuntu's file explorer


    started playing around with chmod, cloned the permissions, still no luck
    then I noticed the permissions on the root of the drive itself and the owner ware different


    then I remembered that I actually used this very same computer to initially copy the data from NTFS to ext4 and in the process the owner was the user account from that computer and not OMV's root!
    after sorting that out by running chmod --reference=root/of/other/drive root/of/first/drive
    the problem was solved!


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!