Raid missing after restart

  • Hi,

    i've restarted my omv 5 after updating it to and configuring Plesk within Portainer.
    After restart my raid is not found anymore.
    The disks are still displayed within omv. The raid disappeared.
    Raid5 consits out of 4 disks 2.73TiB.

    What would be the next step to avoid data loss/recovery.

    cat /proc/mdstat


    fdisk -l | grep "Disk "

    cat /etc/mdadm/mdadm.con

    mdadm --detail --scan --verbose

  • The raid is actually inactive, which would cause it not to show in the gui, the output from mdstat shows 3 out of 4 drives, as does blkid, what is also inexplicable is there is no reference to the array in mdadm.conf.

    For whatever reason /dev/sdb is missing from the array hence the output from mdstat and blkid, but the drive shows up under fdisk.

    First off try mdadm --assemble --verbose --force /dev/md127 /dev/sd[bcde] and post the output, this may return an error on /dev/sdb missing superblock.

  • hi,

    thats my result:

    root@Openmediavault:~# mdadm --stop /dev/md127
    mdadm: stopped /dev/md127

    mdadm --assemble --verbose --force /dev/md127 /dev/sd[bcde]

  • hi,

    as u said the array is back clean and degraded and visible withing omv webclient. Shares are also working.
    See beloew:

    root@Openmediavault:~# mdadm --assemble --verbose --force /dev/md127 /dev/sd[bcd]

    I've not restartet omv so far.
    So what are the next steps to readd the missing drive ?
    i've done the raid status commands and again for a full status for you:

    root@Openmediavault:~# cat /proc/mdstat

    root@Openmediavault:~# blkid

    root@Openmediavault:~# fdisk -l | grep "Disk "

    root@Openmediavault:~# cat /etc/mdadm/mdadm.conf

    root@Openmediavault:~# mdadm --detail --scan --verbose

  • Hi,

    i've used the mentioned command with sda instead of sde.
    sde is my boot disk.

    Error while doing first command. Thought the reason is because its missing anyway.
    so i've done the the second command and it seems to be working.

    Thats the result out of radi menu item within omv webclient

  • Do u have any clou how the raid is lost?

    None as 5 is beta it could be anything, I'm still not sure why mdadm.conf contains no raid arrays, but neither does mine and my 5 set up is just a test.

    Ok I've just run a command on my test machine and my mdadm conf is populated, what's the output of your cat /etc/mdadm/mdadm.conf

  • hopefully the raid is already there after next reboot without any entry within that file.

    Don't reboot yet, wait for the rebuild then run the following omv-salt deploy run mdadm wait for it to complete there appears to be a delay of up to 50 secs then check the mdadm.conf again and under # definitions of existing MD arrays your array should be displayed.

  • ok.
    will be some time after raid is rebuilded. there are still 400minutes left.
    it's the most dangerous part within rebuilding of an raid5 due to the chance of an additional disk failure,....

    i think tomorrom morning i can check if evrything is still ok after the last command.

  • Hi,

    because I do not know what to do the whole day, i've ported my raid to a new system.
    That system has got a backplane.

    After connecting the disks to newly installed omv5 system the same error happend.
    I've got excatly the same result as described in my first post. The same disk left the array and the disks left within the array were busy.

    I've now done the same steps as described above any everything is fine now. But why ?!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!