What am I missing trying to configure static IP adress?

  • Hi all,


    I'm following The Getting Started guide, since I am very new to OMW and servers in general.


    After I try to set a static IP adress, stuff starts going wrong.


    What am I missing?


    I've set
    IPv4
    Method - Static
    Adress - 192.168.0.201
    netmask - 255.255.255.0
    gateway - 192.168.0.1


    IPv6
    Method - disabled


    Advanced settings
    DNS servers - 1.1.1.1
    Search domains - ??? (no idea what needs to be filled in here)
    MTU - 1500
    Wake on Lan - off


    Here's an example of an error I get trying to update a package

  • You specified wrong settings. Perhaps your gateway should be something else. Perhaps the ip should be something else.


    Login to your router and check the settings used for DHCP in it.


    It is a good idea to not only set a fixed ip in OMV but also specify a static lease of that IP, for that device, in the router. Then you can also assign a name to the server.


    Start with asigning a fixed lease to OMV in the routef, then change in OMV.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Hi Adoby,


    Pretty sure IP adress, gateway, netmask are the correct settings.


    The DNS server should also be okay? For the MTU value I used the same value as I saw in the system monitor when DHCP was still on.


    Maybe I can try a different IP address, maybe I've picked one which is already in use or not allowed?


    Unfortunately my router is only accesable through my ISP's website and has very limited options. There is no way to set a static lease for certain IP's...

  • I'm just installing OMV for the very first time. It's pretty much still a clean in install


    I'm following the "Getting started guide", I'm at the point where I'm setting the static IP, but then I noticed something went wrong because I couldn't run any updates with static IP, whilst if I revert to DHCP I can run the updates.
    (this guide https://forum.openmediavault.o…rted-with-Openmediavault/)


    (I'm using OMV 5 because the installer for OMV 4 wouldnt recognize some of the hardware in my pc)

  • Some tests pingíng:


    I also tried restarting my router several times... No change

  • The Getting Started Guide was written for OMV3 and 4.
    OMV5 is still a Beta and, as such, may have a few wrinkles to iron out. (And there is a note in the Guide about what running a "BETA" means. :) )


    Since you're at the start and are already statically addressed - if you can get on the command line, try this.


    systemctl stop NetworkManager.service
    systemctl disable NetworkManager.service


    For the time being, try using your routers IP address as the DNS server.


    Please let us know how it went. This may have a bearing on other issues.

  • If everything is working fine when you use DHCP you can ask the router to assign always the same IP to your NAS.


    Another option is to not care about the IP adress, but use the hostname instead. If your OMV is called "nas" you reach the gui with


    http://nas.local

  • This yielded some unexpected results (I threw in the ip address show just to prove I am in fact connected :))



    If everything is working fine when you use DHCP you can ask the router to assign always the same IP to your NAS.


    Another option is to not care about the IP adress, but use the hostname instead. If your OMV is called "nas" you reach the gui with


    http://nas.local

    That is a neat little trick. Thanks. That could help indeed if I would be stuck with DHCP. However I'd like to have this weirdness sorted out.

  • root@Eddy:~# systemctl stop NetworkManager.service
    Failed to stop NetworkManager.service: Unit NetworkManager.service not loaded.
    root@Eddy:~# systemctl disable NetworkManager.service
    Failed to disable unit: Unit file NetworkManager.service does not exist.

    So it's not running. Hum,, network-manager is running only on Armbian SBC's.


    I'll take it that you changed your DNS server IP address, to your routers IP address and that had no affect. You could try another public DNS server like 8.8.4.4 just to see what happens.
    From time to time, sources may not be available. It's pretty rare, but it happens. Generally, the next day, they're back on line.


    In any case, I don't know of a specific reason why using a static IP address and a pubilc DNS server would cause a name resolution failure. On the other hand you could try the DHCP setting, reboot, and see what happens.
    ________________________________________________________


    If this persists and if you're in a hurry, I'd suggest building OMV4.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!