Access denied from Windows XP desktop PCs

  • XP Win2003 computer cannot connect to Samba shared directory


    Starting from Samba 4.5, the default value of NTLM auth parameter changes from "yes" to "no". As a result, clients using NTLM level LAN Manager authentication are not allowed to log in to Samba server by default. The affected clients include Windows XP, windows 2003, etc.




    Solution (either can be solved):


    1. Samba server smb.conf Restart the SMB service after adding "NTLM auth = yes" in the configuration file.


    2. The Windows XP client modifies the local security settings, security options, and the value of "network security: LAN Manager authentication level" to "send NTLMv2 response only".

    --------------------------------------------------------------------------------------------

    https://www.cnblogs.com/awakenedy/articles/11150049.html

    --------------------------------------------------------------------------------------------
    My solution :

    [global]

    NTLM auth = yes

    min protocol = NT1

  • 1. Samba server smb.conf Restart the SMB service after adding "NTLM auth = yes" in the configuration file.

    You should not edit /etc/smb.conf directly, because changes are overwritten when you later use the OMV webUI. Instead use the Extra Options fields of the SMB/CIFS settings.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!