Quota not working in 0.50: Cannot find mountpoint for device /dev/sdb1

  • Hello,


    After using OMV 4, I moved to 5 to benefit to move to Debian 10.


    When I try setting the quotas, I can this error:


    Fstab have quota on:


    Code
    # >>> [openmediavault]
    /dev/disk/by-label/Samsung840Evo /srv/dev-disk-by-label-Samsung840Evo ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    # <<< [openmediavault]


    Any idea of the issue?


    Merci

  • In 4.x it was working. You may be right as I don't get much using repquota etc...


    Not sure how to best check if the module is loaded but from the mount I don't seem to see the quote arguments being displayed and neither a quota module being loaded. What should I do to manually load it (insmod?)

    Code
    root@OMV-CAM:~# mount
    /dev/sdb1 on /srv/dev-disk-by-label-Samsung840Evo type ext4 (rw,relatime)
    /dev/sdb1 on /sharedfolders/Back type ext4 (rw,relatime)
    /dev/sdb1 on /sharedfolders/Front type ext4 (rw,relatime)
    /dev/sdb1 on /sharedfolders/Side type ext4 (rw,relatime)

    Merci

  • I believe the modules are loaded but it's the line within fstab which is wrong.


    Code
    root@OMV-CAM:~# quota --version
    Utilitaires quotas version 4.04.
    Compiled with: USE_LDAP_MAIL_LOOKUP EXT2_DIRECT HOSTS_ACCESS RPC RPC_SETQUOTA BSD_BEHAVIOUR
    Rapports de bugs à jack@suse.cz
    root@OMV-CAM:~# find /lib/modules/`uname -r` -type f -name '*quota_v*.ko*'
    /lib/modules/4.19.0-5-amd64/kernel/fs/quota/quota_v1.ko
    /lib/modules/4.19.0-5-amd64/kernel/fs/quota/quota_v2.ko
    root@OMV-CAM:~# cat /proc/mounts | grep ' / '
    /dev/sda1 / ext4 rw,noatime,nodiratime,discard,errors=remount-ro 0 0

    I think there is a bug. Can I edit the fstab manually in between, what should be the right syntax?
    BEFORE: /dev/disk/by-label/Samsung840Evo /srv/dev-disk-by-label-Samsung840Evo ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    AFTER???: /dev/disk/by-label/Samsung840Evo /srv/dev-disk-by-label-Samsung840Evo ext4 defaults,nofail,user_xattr,noexec,usrquota,grpquota,jqfmt=vfsv0,acl 0 2


    (this last line didn't work neither)

  • Would you have an OMV 4 fstab entry to check if my fstab is correct?


    What else can I attempt to make it work? I am thinking maybe to partition the drive as a workaround but this is less flexible and I wanted to see if we can understand if this is a bug or a bad config but I agree strange to not see the quota options within the mounting itself.

  • Can you please run the commands and post the output


    Bash
    # omv-salt deploy run fstab
    # cat /etc/fstab
    # omv-salt deploy run quota

    Please make sure that you are on 5.0.10.


    not sure what happened but now it works:
    root@OMV-CAM:~# repquota -a
    *** Rapport pour les quotas user sur le périphérique /dev/sdb1
    Période de sursis bloc : 7days ; période de sursis inode : 7days
    Block limits File limits
    Utilisateur utilisé souple stricte sursis utilisé souple stricte sursis
    ----------------------------------------------------------------------
    root -- 221211572 0 0 2706 0 0


    Here is the output of the commands

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!