kworker/0:+ High CPU usage

  • I recently downgraded my server that I use Plex on as my needs have changed over time.
    I am running OMV 4.1.26 on a HP Proliant Microserver: AMD Athlon II Neo N36L Dual-Core (1.3), 6GB RAM.

    After three week I shut the server down as I had to turn off while some other electrical work was going on.

    I started the server back up and almost immediately noticed a "sluggish" response. I viewed the running processes and immediately found the problem, Kworker was chewing up 60% of my CPU time. I have checked this forum and others but can't find a fix for this.

    I've attached a picture so you can see the difference before and after the shut down.

    I run Docker, with PLex, Wetty and Watchtower containers. That's all this server is used for.

    Any assistance is getting to the root of this problem would be greatly appreciated.

  • It could indicate that the kernel has problems with something. It may be a full filesystem somewhere or some hardware that is broken or turned off or some hardware driver/module that is missing or some hardware that is incompatible with something.

    There are three main ways of figuring out what is the problem. In increasing difficulty order:

    1. Do a quick check in log files to see if some errors are reported. Update everything. Check that all filesystems are correctly mounted. Check that all peripherals are turned on and working. Sometimes simply turning off/on might help. Check cables and power.

    If 1. that fails to show what is the problem:

    2 a. Turn off and unmount as much as possible. If that fixes it, turn on and mount stuff one thing at a time until the problem is back. Then you know what is the problem.

    2 b. An extreme variant is to reinstall OMV from scratch, and carefully monitor while you configure/install software/drivers when the problem is back. Then you know what the problem is.

    If 2. that fails to show what is the problem:

    3. Install perf-tools-unstable and use them to trace and diagnose what the kernel is spending time trying to do.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks for the help. I couldn't find anything in the logs, well anything that I could understand.

    I've unmounted and all drives but the issue was still there.

    I am in all respects a beginner here so the Perf tools option is beyond me. I wouldn't know how to install it or run it.

    I will probably do a reinstallation over the weekend to see if that solves the issue.

    But thanks for your time.

  • Well I tried a full wipe and reinstall and the problem is still there.
    I also ran the Update Management but it made no difference.

    I might try going back to an earlier version of OMV and seeing if that would make any difference, at the moment I'm open to trying anything as it's pretty much unusable as it is.

    I just can't figure out why it would suddenly start using 60% of the CPU for no good reason.

  • I took all the drives out and put them in an Dell PC and reinstalled OMV on to it. Everything is going fine, looks like the Microserver is the issue and not the software.

    Thanks for the help, much appreciated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!