SMB - Only Users with group "adm" can connect.

  • Hello,


    i recently installed OMV to an old Atom-PC.
    In a Docker its also running my PiHole, im using ...backup 4.0.6 and ...flashmemory 4.2.1 from OMV-Extras, all works fine.


    But now im struggling with SMB-Shares.
    No matter what i do, i can only connect to shared folders if i use a User with the Group "adm".
    "users" or my added group called "Handys" wont work.
    OMV-Nutzer-Gruppen.png
    Is there any setting i might missing?
    Or maybe should i use "adm" at all Users? (It dont feels right to me.)


    Please help me to understand what the groups do to shares and rights.


    Regards
    Patrick

    Hardware: AsRock Q1900 (inside case of modified ThinkCentre A57e, type 6306), 4GB RAM, 120GB SSD (BX500), 3TB HDD (WD30EZRX)


    Software: OMV 4.1.28-1, OMVExtras 4.1.16, ResetPerms 3.3, Flashmemory 4.2.1, Backup 4.0.6, USB-Backup 4.0.8-1, clamav 4.1.11-1, Docker-GUI 4.1.6, PiHole 4.3.2

  • I read that document but its only describing a shared folder open for all.
    Even if i try to grant access to guests like in the pdf it wont work.


    (Last night i updatet to OMV 4.1.26-1)

    Hardware: AsRock Q1900 (inside case of modified ThinkCentre A57e, type 6306), 4GB RAM, 120GB SSD (BX500), 3TB HDD (WD30EZRX)


    Software: OMV 4.1.28-1, OMVExtras 4.1.16, ResetPerms 3.3, Flashmemory 4.2.1, Backup 4.0.6, USB-Backup 4.0.8-1, clamav 4.1.11-1, Docker-GUI 4.1.6, PiHole 4.3.2

  • I now deleted all folders, users and groups.
    Restarted OMV
    Dont create any user.
    Strictly following the PDF I created a folder and share for guests.


    I do find the folder in network, but i cant connect.

    Quote from Thunar

    Failed to mount Windows share: Permission denied.


    After that i add a user with group users, add read/write privileges for my test-folder "Musik".
    Result: I can try to login again and again and again. No files or folders to see.


    After that I added "adm" to the group of User "Benutzer" (That was the point i could login before!)
    Result: I can try to login again and again and again. No files or folders to see.


    Now i modified ACL of the Folder to Read/Write for "Benutzer", "adm" and "users".
    Result: I can try to login again and again and again. No files or folders to see.

    Now i cant use my files in any way.


    Is there a "reset to default" i can use?
    Can i delete/override a (maybe corrupt) config on the system drive?


    Any other ideas?



    Regards,
    Patrick

    Hardware: AsRock Q1900 (inside case of modified ThinkCentre A57e, type 6306), 4GB RAM, 120GB SSD (BX500), 3TB HDD (WD30EZRX)


    Software: OMV 4.1.28-1, OMVExtras 4.1.16, ResetPerms 3.3, Flashmemory 4.2.1, Backup 4.0.6, USB-Backup 4.0.8-1, clamav 4.1.11-1, Docker-GUI 4.1.6, PiHole 4.3.2

  • Sadly I used resetperms before deleting all Users and Folders.


    There seems to be another issue i ran into.

    Hardware: AsRock Q1900 (inside case of modified ThinkCentre A57e, type 6306), 4GB RAM, 120GB SSD (BX500), 3TB HDD (WD30EZRX)


    Software: OMV 4.1.28-1, OMVExtras 4.1.16, ResetPerms 3.3, Flashmemory 4.2.1, Backup 4.0.6, USB-Backup 4.0.8-1, clamav 4.1.11-1, Docker-GUI 4.1.6, PiHole 4.3.2

  • I have searched for a quite old posting from @tekkb where he has explained very good how to configure a share with user permissions. And I found it: How to make a good Media share for Emby and PlexMediaServer, especially post #2 and the following.


    It´s old, but in principle it should work for OMV 4 also.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Once again I deleted all my trial and error users and folders, cleared the ACL and after a restart i was able to create shares, folders and users i could connect to.


    It seems to work now and my "adm"-problem is also solved.


    Thanks for your help cabrio_leo :thumbup:

    Hardware: AsRock Q1900 (inside case of modified ThinkCentre A57e, type 6306), 4GB RAM, 120GB SSD (BX500), 3TB HDD (WD30EZRX)


    Software: OMV 4.1.28-1, OMVExtras 4.1.16, ResetPerms 3.3, Flashmemory 4.2.1, Backup 4.0.6, USB-Backup 4.0.8-1, clamav 4.1.11-1, Docker-GUI 4.1.6, PiHole 4.3.2

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!