IPv6 - Not running

  • Good day,
    I would like to ask what it looks like with IPv6 support for version 5.x. We haven't turned it on via web interface or omv-firstaid yet. If I turn it on manually, it is disabled after restart.


    The same goes for IPv6 support in Docker.


    Thank you for answer.

  • I tried to turn it on. It is not even receiving a ipv6 address. Anyone else has been able to work with IPv6 support in OMV 5?


    If I do grep "disable_ipv6" /etc/sysctl.conf /etc/sysctl.d/*.conf, it shows:


    /etc/sysctl.d/99-openmediavault.conf:net.ipv6.conf.all.disable_ipv6 = 1
    /etc/sysctl.d/99-openmediavault.conf:net.ipv6.conf.default.disable_ipv6 = 1
    /etc/sysctl.d/99-openmediavault.conf:net.ipv6.conf.lo.disable_ipv6 = 0


    Why is it deactivated?


    changing all values to 0 and restarting the server did the job. It finally obtained an ipv6 address.


  • Thanks. This worked for me, although the user interface doesn't show the ip6 address when set to auto. I also had to run 'sudo systemctl disable dhcpcd' to disable dhcpcd as I was getting two network interfaces and IP addresses. 1 static IP from /etc/system.d/network and the other from /etc/dhcpcd.conf

  • yes, it's worked . thank you.


    When I didn't install ovm, the device was able to get ipv6 addresses. But after I installed ovm and rebooted the device, the ipv6 address was gone. Even though I configured the network card's ipv6 to DHCP in the web interface, the device still couldn't get it.


    After modifying the above configuration and rebooting the device, the ipv6 address is normally obtained.



    I looked at the script and thought it might have something to do with uninstalling 'network-manager', but decided.


    However, I think the installation should have ipv6 access enabled so that we can more easily access the public network via the ipv6 address of the device. While this increases device risk, I think it can be avoided by enhancing the security of ovm.


    The carriers in my area are already fully ipv6 enabled, and access over ipv6 is a trend. I hope the authorities will be able to open it during installation, or if ipv6 is enabled when configuring the network card in the web interface, the system should be able to get the ipv6 address normally.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!