NFS Errors : shutting down socket

  • I have OMV 4.1.7 (Arrakis) installed and running with NFS and SMB shares, it works perfectly and I'm very happy, but only for about 45 minutes!

    During that time I can stream audio, and video via NFS to multiple devices, and copy to or from shares using SMB all simultaneously. CPU usage
    remains fine as does memory usage, and no errors occur. If I simply stream audio (for instance) for the 45 minutes all is well, and then between about 40 and 60 minutes I start getting errors:

    Oct 21 14:58:48 raspberrypi kernel: [ 3194.081996] rpc-srv/tcp: nfsd: sent only 114376 when sending 131136 bytes - shutting down socket
    Oct 21 15:04:29 raspberrypi kernel: [ 3535.202917] rpc-srv/tcp: nfsd: sent only 61504 when sending 131136 bytes - shutting down socket
    Oct 21 15:08:37 raspberrypi kernel: [ 3782.883453] rpc-srv/tcp: nfsd: sent only 8256 when sending 131136 bytes - shutting down socket
    Oct 21 15:12:19 raspberrypi kernel: [ 4004.323973] rpc-srv/tcp: nfsd: sent only 64 when sending 131136 bytes - shutting down socket

    As you can see, once they start, they happen quite regularly. I get silences of many seconds in my music, while the client reestablishes the socket connection. Its a relatively 'vanilla' install, and although I tried altering some things through the GUI control panel I haven't delved into Samba in depth. I have tried varying buffer sizes through the client parameters but nothing so far seems to help. Any ideas guys (and girls)? (SMB seems to suffer similar problems but without such specific error messages, so I'm sticking with NFS.)

  • 4.1.7 and 4.1.26 are both Arrakis. But 4.1.26 is the current version. 4.1.7 is quite old. So I assume you have not updated for a long time. This probably includes other updates of the under laying Debian 9.

    Use the "Update Management" in the GUI of OMV.

  • If you installed recently with the image from here…/Raspberry%20Pi%20images/

    then the installation has not finished correctly. If the first boot runs successfully your OMV is updated to the latest version.

  • I couldn't get the Update Management working on my install, so I started again from the sourceforge download pages latest build, which was still 4.1.7. This time I was able to do updates to 4.1.26 and as you suggested this seems to have resolved whatever the issues were. So; many thanks macon, I owe you one!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!