Docker container and Virtualbox VM are unable to reach each other within OMV

  • I have this weird problem regarding the networking between the two applications - Docker and Virtualbox. Some of my Docker containers are using macvlan. macvlan works wonderfully.
    I have an ldap server (slave) running on Virtualbox and Docker container (emby). I am trying to authenticate my users via ldap, but unable to do so. When I checked the Emby (container) logs, it says "No route to host 10.1.7.40:7389". This is weird because they are both in the same subnet.


    Here is what I have done so far:

    • The slave ldap server (VM) and the emby (docker) are both in the same subnet of 10.1.7.0/24, but can't see each other.
    • From the slave ldap server, I cannot ping the emby. However, I can see the emby's MAC address in the slave ldap server arp table.
    • If I ping the emby from a different subnet or even remotely, I can ping it and it is responding. I can also watch my movies, etc. So the network is working.
    • If I point the emby to use the master ldap server which is located in a different subnet, it worked.
    • I tried to use my other instance of emby from a different NAS to authenticate to the slave ldap server, this worked as well.

    With all these tests, I can safely say that the IP connectivity and openldap are working fine. But the problem exist between Virtualbox and Docker application. Has anyone have encountered this issue or a resolution?
    This is the default iptable on my OMV. I have not configured any firewalling on the OMV.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!