Cannot create shared folder on new or existing drive

  • Out of the blue I am unable to create new shared folder on new or existing drives witch already got shared folders



    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl restart 'sharedfolders-AppData.mount' 2>&1' with exit code '1': Job for sharedfolders-AppData.mount failed. See "



    status sharedfolders-AppData.mount" and "journalctl -xe" for details.

  • You are surely using '/sharedfolders/xxx' in a plugin, e.g. Docker. This is not allowed because it results in the problems you now have. The '/sharedfolders' shortcuts were only implemented to make navigation on CLI easier. Using them for example in Docker means that Docker locks the dirs and systemd fails when OMV tells it to reload them.

  • You are surely using '/sharedfolders/xxx' in a plugin, e.g. Docker. This is not allowed because it results in the problems you now have. The '/sharedfolders' shortcuts were only implemented to make navigation on CLI easier. Using them for example in Docker means that Docker locks the dirs and systemd fails when OMV tells it to reload them.

    Thank you for taking time to answer to me, I am sure your busy with OMV 5 development but I am pretty sure I did not do what you are mentioning since my level of expertise is rock bottom! the only thing I did was to move docker to an external drive Move docker /var/lib/docker folder on external drive
    I think you are right I have probably done it.
    How I got there no idea.
    how to fix it?
    If you want I can upload my journalctl -xe

  • You need to check on your server which is the correct path.


    I assume you already have the folder "docker" and you want to use it. Before you used it with /sharedfolders/AppData/docker
    and this would be /srv/dev-disk-by-label-WD_10TB_1/AppData/docker


    using the complete path.



    But - as mentioned above - you have to confirm this on your server.

  • Got news:


    Doing that get me to square 1 with no possibility to add a shared folder!
    Maybe the name AppData is reserved
    with the link docker in var lib to
    /srv/dev-disk-by-label-WD_10TB_1/AppData/docker


    Went back to /srv/dev-disk-by-label-WD_10TB_1/docker and it is working again very strange.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!