Will OMV5 support the remote-mount plugin?

  • Hi. I successfully installed OMV5 BETA on Armbian Buster. Everything seems to work fine :)


    I've got a question about the "remote-mount" plugin which I used on OMV4 for the old NAS backups.
    Will this plugin be available in OMV5? If yes, is there any known ETA for it? I'm asking, because if this plugin was dropped, then I will already try to find an alternative for it.


    Greetings.

  • Will this plugin be available in OMV5? If yes, is there any known ETA for it? I'm asking, because if this plugin was dropped, then I will already try to find an alternative for it.

    Eventually I plan to port it. I really hate that plugin. It generates sooo many support requests caused by improper setup and/or doing bad things with it. The plugin needs to be flexible though. I don't have an ETA. I need to finish porting rsnapshot first and barely have any time for that.


    If the old server supports rsync, you don't need remotemount.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I vote for this too. I have a remote windows server that I am offering to the local users as NFS shares and without this plugin it would be a lot more complicated to do this.


    Another use is to connect to a remote repository to be used as target bor backups so it is quite useful.

  • Thank you. Unfortunately, for now it doesn't want to work for me:

    Quote

    0 2 +//192.168.1.130/40b40e40r40n40a40d40e40t40a40 /srv/402be38b-a450-4be2-a1f7-6433854231d9 cifs _netdev,iocharset=utf8,vers=2.0,nofail,credentials=/root/.cifscredentials-11a9d9b9-265b-41bf-b8a6-c45da5a6a5f8 0 0 # <<< [openmediavault] Summary for odroidn2 ------------- Succeeded: 10 (changed=5) Failed: 1 ------------- Total states run: 11 Total run time: 911.169 ms


    I noticed that /etc/fstab has:

    Quote

    //192.168.1.130/^@40b^@40e^@40r^@40n^@40a^@40d^@40e^@40t^@40a^@40 /srv/402be38b-a450-4be2-a1f7-6433854231d9 cifs _netdev,iocharset=utf8,vers=2.0,nofail,credentials=/root/.cifscredentials-...


    is "^@40" an expected encoding for the share name?


    When I removed the remote share from the "Remote Mount" page, the configuration saved successfully, so I'm sure it doesn't fail due to any other local mount.


    EDIT:
    (this is the line with new entry)

    Quote

    root@odroidn2:~# mount -a


    mount: /etc/fstab: parse error at line 8 -- ignored


    EDIT2:
    I manually edited file:
    /srv/salt/omv/deploy/fstab/90remotemount.sls


    And replaced:
    {% set share = '//' + mnt.server + '/' + mnt.sharename | replace('', '\\040') %}
    to:
    {% set share = '//' + mnt.server + '/' + mnt.sharename %}


    And the problem is gone.


    Thank you once again for this plugin!

  • And the problem is gone.

    I just fixed the plugin a little bit ago. 5.0.1 is in the repo. Removing the replace line is not the correct fix. It is just supposed to replace spaces with \\040.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • I just fixed the plugin a little bit ago. 5.0.1 is in the repo. Removing the replace line is not the correct fix. It is just supposed to replace spaces with \\040.


    Perfect. Thank you. I don't have shares with spaces in name, that's why my edit didn't cause problems for me.
    I can confirm that after "apt upgrade" everything works as expected.

  • Hi ryecoaaron, hope you're well.


    I've just installed OMV539 with remote mount. I kept getting errors whenever I tried to mount any share.

    I also have used this parameters on OMV4 when mounting to give me write access as I'm using NAS as download folder.

    file_mode=0777,dir_mode=0777,_netdev,iocharset=utf8

    it has been working flawlessly on OMV4.


    any help would be much appreciated. Thanks

  • I kept getting this error which I think it's related to python3.7


    "DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly"

  • UPDATE


    I'v solved it, I had to make the shares on windows public not private as it doesn't like the network username and password it wanted to use the local user, not how i wanted it but will have to do for now.



    Hi Ryecoaaron,


    iv been trying to get remote month to work on my omv 5.5.1 installed on RPI Buster Lite and i keep getting the following error


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run fstab 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/utils/decorators/signature.py:31: DeprecationWarning: `formatargspec` is deprecated since Python 3.5. Use `signature` and the `Signature` object directly *salt.utils.args.get_function_argspec(original_function) raspberrypi: ---------- ID: create_remotemount_mountpoint_419b496b-d625-4171-ace1-03ab6d551ca6 Function: file.accumulated Result: True Comment: Accumulator create_remotemount_mountpoint_419b496b-d625-4171-ace1-03ab6d551ca6 for file /etc/fstab was charged by text Started: 11:49:55.168057 Duration: 9.79 ms Changes: ---------- ID: mount_filesystem_mountpoint_419b496b-d625-4171-ace1-03ab6d551ca6 Function: mount.mounted Name: /srv/419b496b-d625-4171-ace1-03ab6d551ca6 Result: False Comment: mount error: could not resolve address for DATASERVER: Unknown error Started: 11:49:55.181174 Duration: 790.704 ms Changes: ---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: Changes were made Started: 11:49:55.975204 Duration: 20.133 ms Changes: ---------- diff: --- +++ @@ -4,5 +4,5 @@ # a swapfile is not a swap partition, no line here # use dphys-swapfile swap[on|off] for that # >>> [openmediavault] -//DATASERVER/wwwroot /srv/21fdb491-d9dd-46d0-8235-293cec1abb76 cifs _netdev,iocharset=utf8,vers=2.0,nofail,credentials=/root/.cifscredentials-c38339ec-4b5e-4451-a776-23a2950e4a40 0 0 +//DATASERVER/wwwroot /srv/419b496b-d625-4171-ace1-03ab6d551ca6 cifs _netdev,iocharset=utf8,vers=2.0,nofail,credentials=/root/.cifscredentials-3115da62-ca78-41aa-8b85-a621300ca587 0 0 # <<< [openmediavault] Summary for raspberrypi ------------ Succeeded: 2 (changed=1) Failed: 1 ------------ Total states run: 3 Total run time: 820.627 ms

    The shares are on a windows server 2019 which work fine across other windows are i can also access the shares from ubuntu, linux mint etc, i also have tried it on a rpi with desktop and i can access it but omv wont let me connect to them.


    Quote

    Any ideas?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!