WebUI Freigaben kommen nicht bei NFS Server an

  • Via OMV WebUI habe ich eine NFS Freigabe eingerichtet. Leider wird sie nicht in '/etc/exports' verewigt. Ein 'showmount -e localhost' hat ergeben, das es keine Freigaben gibt. Und natürlich sind im Dashboard beide NFS Lampen grün.
    Kann mir jemand sagen was hier falsch läuft? Oder wo ich suchen muss?
    Syna

  • Can not reproduce it.


    On NAS:


    On other host:

    Code
    ~/git/openmediavault/vagrant   master-upstream ✔  $ showmount -e omv5box.local
    Export list for omv5box.local:
    /export 0.0.0.0/32
    /export/test 0.0.0.0/32
  • Mittels OMV>Dienste>NFS>Freigaben habe ich eine neue Freigabe erstellt (lese/schreibrechte gesetzt, 192.../24 freigegeben). Diese konnte ich auf den Clienten nicht mounten. Eine Überprüfung mit 'showmount' ergab: Export list for localhost:. Dann habe ich mir die /etc/exports mit 'cat' angeschaut und festgestellt, das dort nur die Auskommentierte Beispielkonfiguration drinnen steht.
    Das WebUI hat die Freigaben nicht in der exports gespeichert.


    Code
    # /etc/exports: the access control list for filesystems which may be exported
    # to NFS clients. See exports(5).
    #
    # Example for NFSv2 and NFSv3:
    # /srv/homes hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
    #
    # Example for NFSv4:
    # /srv/nfs4 gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
    # /srv/nfs4/homes gss/krb5i(rw,sync,no_subtree_check)
    #
  • >Do you have applied the cofiguration by pressing the yellow Apply button?
    ja, es gab sogar schon ein paar nas reboots und die Freigabe wird immer noch im WebUI angezeigt


    Code
    omv-salt deploy run nfsd
    ERROR: The state 'nfsd' does not exist

    Wir kommen der Sache wohl näher....


    Gabs beim initialisieren von OMV ein Problem? Habe erst Debian Netiso installiert und danach OMV

  • Du hast da einen Vertipper. Bitte ohne das "d" am Ende nochmal ausführen:


    omv-salt deploy run nfs

    Ups, ja ein Tippfehler. Ohne "d" sah es dann wesentlicher erfolgreicher aus (auszug):


    Und 'showmount' funktioniert jetzt auch:

    Code
    Export list for localhost:
    /export 192.168.0.0/24
    /export/abc-share 192.168.0.0/24

    Ich danke euch beiden für die hilfe.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!