2,5" USB Drive Spindown not working

  • Hey guys,


    After successfully setting up my Raspberry Pi 4B with OMV 4 I cant get my external HDD to spindown with Advanced Power Management..
    I'vre tried different setting on the OMV GUI, with different combinations
    I followed the guide for hd-idle (https://www.libe.net/omv-hd-idle) it still does not work.
    Most topics reguarding the topic on this forum are not related to USB drives, if I'm not wrong.


    Is there a known issue with USB drives? How do I setup spindown correctly?
    The external drive is a seagate expansion portable 4tb


    I'm a little worried about running the drive 24/7

  • The USB enclosure should handle the spindown. But only if you actually stop reading/writing to the drive. Do you have anything that use the drive, causing it to not spin down?


    But not all USB enclosures were created equal. Check the documentation for the enclosure. Perhaps there is some software, from the drive manufacturer, that can be used to change the configuration of the drive?

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited once, last by Adoby ().

  • i have same problem. i have USB Seagate 4tb. and he not turning spin down mode, but if i connect HDD to the iMac, during 10-15 minut HHD go to spindown mode if i do not use HDD.


    i use OVM5 and debianRaspbian Buster Lite Release date:2019-09-26 Kernel version:4.19

    This problem as OVM4 as and OVM5

  • If you make a fresh install, and ONLY wipe and add the external drive, formated as ext4. And disconnect the network. Will the drive spin down?
    If yes, then you know that it is you that caused the drive to not spin down.


    If no, then you know that OMV and/or Debian is to blame. Or possibly you again if the external drive is not sold as suitable for use with Linux as a 24/7 NAS drive.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • I've had a similar issue with a Seagate 2,5"BackupPlus 5TB disk. Turned out I had to 'enable' spindown, including timeout @ drive level using one of these tools (can't exactly remember which one):



    Since then, it does spindown in a reliable way on both an Odroid and OrangePi board running OMV4.x

  • I've had a similar issue with a Seagate 2,5"BackupPlus 5TB disk. Turned out I had to 'enable' spindown, including timeout @ drive level using one of these tools (can't exactly remember which one):



    Since then, it does spindown in a reliable way on both an Odroid and OrangePi board running OMV4.x

    How do you run this tools on the OMV?

  • I've had a similar issue with a Seagate 2,5"BackupPlus 5TB disk. Turned out I had to 'enable' spindown, including timeout @ drive level using one of these tools (can't exactly remember which one):



    Since then, it does spindown in a reliable way on both an Odroid and OrangePi board running OMV4.x

    Thats funny, Ive found a similar software, but it only worked on Windows 7.
    I set the spindown timer to 5 minutes and apperently it does work on my PC but not with omv.. did you set the spindown on omv or did you left anything deactivated?

  • When it comes to external USB drives not working correctly with Linux, it might be helpful if you:


    1. Check if the drive is sold as being suitable for use with Linux. Some USB interfaces don't work correctly/fully in Linux. Some USB interfaces may not be identified and handled correctly by Linux.


    2. Try the drive using some other Linux version for testing. OMV is built on top of Debian. If the drive doesn't work correctly on Debian, then it won't work correctly with OMV.


    3. When you test, make sure NOT to have the drive formatted as NTFS or FAT32. EXT4 is a common choice very good for testing.


    4. Check if the manufacturer provides some tools or utilities to update or change the behavior of the drive. If they do, it is possible/likely that standard tools and utilities will not work correctly/fully with the drive.


    5. Make sure the drive is suitable for the intended use. Using a SMR drive intended for sporadic backups of desktop computers as a 24/7 general purpose NAS drive is likely to cause problems and/or give poor performance. It might still be great for backups of the NAS.


    6. Google something like "+linux problem +brand +model" with the exact brand and model of the drive. Then you may find if it is a common problem and perhaps even if someone found a fix.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • thanks for your hekp Adoby
    apperently the spindown does work now after using the Seagate Tool
    I dont know why it did not work yesterday...I did not change any settings but today the drive spins down xD


    thank you all for your help :)

  • I just want to say in passing that my USB drive WD 3TB "my book 1230" did not work with the spin down on OMV either.
    I have installed and configured "HD Idle" - It works very well.


    HowTo


    This HowTo is 2 years old, it has newer version of HD Idle https://sourceforge.net/projects/hd-idle/files/hd-idle-1.05.tgz

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • I set the spindown timer to 5 minutes and apperently it does work on my PC but not with omv.. did you set the spindown on omv or did you left anything deactivated?

    I've set the spindown on the drive "firmware" using Seatools (to 15mins I think) on windows and then used the default drive spindown settings in the OMV webgui (under Disks > Select disk > edit > 1 - minimum power usage with standby (spindown).


    I've set it to 10mins, it seems. Not sure if that matches the settings in Seatools and which setting is honoured when different, but it does reliably spindown.

  • You might want to check the transfer speed once you enabled the spindown settings. In my case (WD Elements) the writing speed dropped from 80/90 MB/s to 3/4 MB/s for some reasons.
    After I while I found out that it was one of the SMART services (even if I did not enabled them) that was keeping my external HDD awake. Once disabled (I did not need it) the HDD went to sleep/spindown without setting anything in OMV. I also did not need hd-idle.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!