Ironwolf click sound in HC2

  • Hi I have been trying to add a 12tb ironwolf pro to a Hc2 with openmediavault 4 and everything goes well apart from when the disk is mounted it constantly says this click sound watch video on my cloud server:


    https://nextcloud.rmortensen84…dex.php/s/WSAHFAfaijXQFN5



    I do not understand that a new hard drive should make this kind of sounds. I have 2 Odroid hc2 and have tried in both of them with the same result. Is it the hard drive or a problem with the Odroid Hc2 ? - I have also had a Toshiba N300 8TB behaved in the same way becoming more and more afraid of it is a problem with these HC2 devices.

  • I turned off Advanced Power Management (APM) and updated the firmware from the beginning but it does not solve the problem.


    I have contacted seagate who must make an RMA on this hard drive if this problem persists.

  • I had this clicking sound. After I updated the firmware, as @macom suggests above, it went away.


    I always reflash the firmware anyway, to set spindown, when I get a new HC2. No clicking sounds.


    I use several Ironwolf HDDs.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited once, last by Adoby ().

  • Okay but I updated the firmware on my hc2 with that command via the wizard:

    Code
    ./JMS578FwUpdate -d /dev/sda -f ./JMS578-Hardkenel-Release-v173.01.00.02-20190306.bin -b ./backup.bin -t 15


    But this does not solve the problem. I am soon tired of Hc2 / OMV 4.0 - It is a brand new hard drive it MUST NOT behave like this at 2 Hc 2 units. They really suck. Don't have the same problems with a server (PC) so that will probably be the solution soon. Because one cannot live with devices that destroy one's hard drives.

  • The output from that command would be interesting to see...


    Using SBCs as NAS is not for everyone. They demand a willingness to experiment and try things.


    I have found HC2 with OMV and IronWolf HDDs to be an excellent combination. Rock steady and performant. As long as you reflash and don't touch the physical disk properties in OMV.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • When you throw them out call me so I will know where to find them. :D

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Hardware: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - NanoPi M4 (v.1), backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user trying to convert to Linux on a HP dx2400, Debian 10 XFCE.

  • Code
    ./JMS578FwUpdate -d /dev/sda -f ./JMS578-Hardk enel-Release-v173.01.00.02-20190306.bin -b ./backup.bin -t 15
    Update Firmware file name: ./JMS578-Hardkenel-Release-v173.01.00.02-20190306.bin
    Backup Firmware file name: ./backup.bin
    Auto spin-down timer: 15 min.
    Backup the ROM code sucessfully.
    Programming & Compare Success!!
    ~/JMS578FwUpdater# ./JMS578FwUpdate -d /dev/sda -v
    Bridge Firmware Version: v173.1.0.2


    Where on that page do you see a newer version than this one?

  • There is one above. The "standard" fw. But the one you used should work. It is the one I used.


    I assume that you really power cycled afterwards (pulled the power plug) and you haven't touched the physical properties of the disk in OMV?


    I'm out of suggestions...

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Yes I made one


    Sudo Shutdown


    And unplugged and plugged it back into the device after firmware update.
    And I haven't made any changes to disk settings.


    But your 12 tb seagate irowolf units do NOT make these sounds?


    Because then I have to get a rma on the disk once more then as I say is one I just received by mail from seagate.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!