plex enabled but not showing in services

  • hi -


    sorry in advance if this is a stupid question.


    Really enjoying playing with OMV and linux but are new to me...


    I'm trying to install plx, but I can't see it listed as a service.


    Have installed OMV extras and enabled plex via that.


    from doing a bit of googling, and using terminal it looks as though plex hasn;t been installed completely/correctly, but I'm too green to know that for sure...


    Anyone got any idea - hoping my OMV jouirney isn;t about to end here....

  • You need to return to the OMV-Extras tab and enable the Docker repository then enable the Docker plugin from the plugins tab. Once you get Docker up and running you can install Plex. There are several ways to skin this cat, so look in the guides for “Plex”.
    Good luck and check back if you run into a wall.

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV Version: Ver. 5 (current) - Hardware: NanoPi M4, Nextcloud, Plex, Airsonic, Booksonic, Calibre, & Heimdall - Acer Aspire T180, backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2, and HP dx2400, Debian 10 XFCE.

  • There are several ways to install Plex on OMV.
    @dddddddddddddddd tried to install Plex as a Plugin on OMV4
    @Agricola is proposing to install Plex in Docker


    The maintainer of the Plex plugin will not spend much (any) effort on it any more. One reason is, that it has been causing many troubles in the past. Another one is, that there will be no Plex Plugin in OMV5 any more


    So you have to decide if you want to trouble shoot the Plex plugin issue or if you want to become familiar with Docker and install Plex in docker. Many plugins will move to docker with OMV5.


    I vote for docker. And as you are just starting with playing, I also vote for OMV5.

  • Thanks guys!


    Did quite a lot more digging and hit another snag - let me talk you through the steps....


    1. decided to follow @macom s advice and try the Docker route
    2. enabled docker CE in OMV-extras
    3. went back to plugins, and guess what? have no available plugins for Plex or Docker
    4 Hit check to refresh the plugins list
    5. got the following error:

    so, now I'm thinking DNS...


    Did a bit of googling around that and have:


    • installed dnsutils (wasn't previously)
    • Changed the DNS entries under system>network>interfaces>my ethernet card
    • Have tried an apt-clean

    Any more thoughts?!?


    dd

  • Please be aware that there will be no docker-gui-plugin in OMV5 any more. It will be replaced by Portainer.


    As you are just about to start with OMV and docker, I suggest you start with OMV5 even if it is no labeled as stable at the moment.

  • thanks @macom.


    err -may have broken something here. Can no longer access the web interface.


    Jumped on my omv box and the ip is correct. guess I've broke something in the interfaces dialogue which is causing the issue. Any pointers you can give me in terms of further googling?

  • thanks @macom appreciate the help.


    Done a bit more digging since the above - looks to be network card related. Can access with ethernet cable to a different laptop so I know the cable and the router are good. getting a few error when I run "ip address", will try the above but got to step out for a few hrs :)"

  • @macom


    ok so, omv-firstaid helped. Back on the web interface and also resolved the previous "could not resolve host" issues. got another error for you though... :)



    Err:36 https://download.docker.com/linux/debian stretch/stable amd64 Packages
    server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none


    I should explain that I've uninstalled and reinstalled omv-extras already as some google-fu revealed that sometimes fixes, but no luck.


    Any ideas?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!