SOLVED Upgrade from OMV 4 to OMV5

  • Hello,

    I have found another to make the upgrade and it works

    rm /etc/apt/sources.list.d/omv-extras-org.list
    vi /etc/apt/sources.list.d/openmediavault.list
    -Write in it
    deb usul main
    -empty other lines
    - Upgrade debian

    sed -i 's/stretch/buster/g' /etc/apt/sources.list
    apt update

    -always answer No
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" upgrade
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" dist-upgrade

    -To solve the DNS problem that doesn't work anymore (it is possible that it will be needed later a second time)
    sudo systemctl disable systemd-resolved.service
    systemctl stop systemd-resolved.service
    sudo rm /etc/resolv.conf
    sudo vi /etc/resolv.conf
    systemctl start systemd-resolved.service
    sudo systemctl enable systemd-resolved.service
    - End of the DNS Problem

    -Control that everything is fine
    apt-get update
    apt-get upgrade

    apt-get purge openmediavault-*
    - remove necessary things if there are errors (zfs, docker...)

    - Solve the error 502 when omv-firstaid is done.
    apt-get purge openmediavault
    apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" install openmediavault-keyring openmediavault
    omv-confdbadm populate
    -- After that omv-firstaid won't kill omv anymore---------

    - Install the extras from version 5
    dpkg -i openmediavault-omvextrasorg_latest_all5.deb

    - Go in the GUI

    Allow backport
    Do Update and Upgrade from GUI
    Select new kernel 5.2 by default

    - In a terminal to compile ZFS (or use the proxmox kernel)
    apt-get install linux-headers-$(uname -r)

    - in the GUI
    install mv-zfs 5
    - in a terminal
    /sbin/modprobe zfs

    apt-get update
    apt-get upgrade
    apt-get reinstall zfs-dkms
    - correct the problem with the mount (rm -R with the directory if the mount is not possible

    apt-get reinstall zfs-dkms
    - This time all will be fine

    apt-get update
    apt-get dist-upgrade

    Now it works perfectly (in a virtual machine)

    Edited once, last by marc_al: found a way to make it work in a new way ().

  • for mine, i had

    - nano and not vi

    - i got the below error,

    E: The value 'stretch' is invalid for APT::Default-Release as such a release is not available in the sources

    needed to change the below stretch to buster

    root@nas:/etc/apt# cat apt.conf

    APT::Default-Release "stretch";

    APT::Install-Recommends "false";

    APT::Install-Suggests "false";

    after apt-get purge openmediavault-*

    i then ended up with WARNING: Master hostname: 'salt' not found or not responsive. Retrying in 30 seconds

    in a loop i couldn't break out of.

    had to goto console kill all apt processes and run dpkg --configure -a

    openmediavault-diskstats remove returns dpkg error code 1

    run apt --force-yes install openmediavault-diskstats

    had to forece remove the other openmediavault-* packages that did not get removed earlier.

    had to disable a bunch of services that appear to have been turned on as part of the process. e.g. ctdb and samba-ad-dc

    had to run mysql upgrade

    had to remove python 7.1 as it kept throwing up pam errors

    had to remove mysql 5.5

    had to remove mariandb 10.1

    was receiving error MySQL: “Access denied for user ‘debian-sys-maint’@’localhost'”

    corrected with below thanks to https://mirzmaster.wordpress.c…ebian-sys-maintlocalhost/

    deleted old non-existent drives from /etc/openmediavault/config.xml (system has gone from OMV3->OMV4-OMV5)

    run omv-salt stage run all

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!