nextcloud error updating

  • hey all.


    i'm running omv 4.1.27-1
    docker is latest version, all docker images are automatically updated.


    i have nextcloud 16.05
    i now see theres an update for 17.01.
    when i go into settings, admin, overview in nextcloud. i hit the update button.
    this brings me to the update page, the update initializes ok, when i hit the start update i get an error.
    the error says
    Check for expected files
    Parsing response failed. File not found.



    i have searched google for fixes and most are old from 2017 and 2015.
    the latest solution was to update through cmd updater.
    is that the only way to update when using reverse proxy?

  • so something is not right with my install.
    so i tried to add /index.php to the end of the page i'm updating on.
    this brings me to the update page and it asks to provide my updater.secret hash. i enter the secret from my nextcloud config.
    i get an error that says secret invalid.


    maybe i should provide a screenshot.

  • so i did reinstall nextcloud.
    Here's what i did.
    I stopped all the services.
    renamed nextcloud data folder to nextcloud_old.
    re-ran my docker compose file.


    at this point everything seemed fine.
    I know have another inssue, it seems like the nextcloud data is my my os drive.
    I'm not sure how this would have happened, as i did not change anything from my docker compose file from the last time.
    Is there a way to move the data base file?

    • stop the container
    • move the data folder to the new location
    • modify the docker-compose file so that it uses the correct path for the data folder (or modify the settings in Portainer)
    • run the docker-compose file (or deploy the container in Portainer if you choose the portainer option under 3)
  • Then I have no idea why you data ended up on your root drive unless you specified it like that.


    Have you tried the steps in post 7?

    not yet

    How do you know they are on your OS drive?
    Post your docker-compose.yml

    omv says my os drive is full. nextcloud has a warning im running out of space. the space left is the same amount in both places.


    i just found a nextcloud folder in shardedfolders. that called nextcloud. i also have one in sharedfolders/appdata. the appdata is where nextcloud use to be.
    i ran du -h and the nextcloud folder in sharedfolders is only 8gigs. that is not big enough to fill my os drive. my os drive is 101gigs.
    i stopped nextcloud, nextclouddb and letsencrypt, i than cd to shared folders and ran mv nextcloud nextcloud_old. im getting an error resource busy.


    so to recap heres how many nextcloud folders i have and the location


    1.original
    /sharedfolders/appdata/nextcloud_old


    what i thought was new
    /sharedfolders/appdata/nextcloud (this is the path in my docker.yml)


    this is one i think nextcloud is using
    /sharedfolders/nextcloud (this is the one im now trying to rename, it's also only 8gigs in size.

  • services:
    nextcloud:
    image: linuxserver/nextcloud
    container_name: nextcloud
    environment:
    - PUID=1001
    - PGID=100
    - TZ=America/New_York
    volumes:
    - /sharedfolders/AppData/Nextcloud/config:/config
    - /sharedfolders/AppData/Nextcloud/data:/data
    depends_on:
    - mariadb
    ports:
    - 450:443
    restart: unless-stopped
    mariadb:
    image: linuxserver/mariadb
    container_name: nextclouddb
    environment:
    - PUID=1001
    - PGID=100
    - MYSQL_ROOT_PASSWORD=mine
    - TZ=America/New_York
    volumes:
    - /sharedfolders/AppData/Nextclouddb:/config
    restart: unless-stopped
    letsencrypt:
    image: linuxserver/letsencrypt
    container_name: letsencrypt
    cap_add:
    - NET_ADMIN
    environment:
    - PUID=1001
    - PGID=100
    - TZ=America/New_York
    - URL=my url
    - DNSPLUGIN=blaize
    - SUBDOMAINS=www,
    - VALIDATION=http
    - EMAIL=mine # define email; required to renew certificate
    volumes:
    - /sharedfolders/AppData/Letsencrypt:/config
    ports:
    - 444:443
    - 81:80
    restart: unless-stopped

  • Is best practice to use the definitive folder names (e.g. /srv/dev-disk-by-label-something) instead of the /sharedfolders. This way you also know where your folders really are.

    yeah i just realized you should not be using the shared folder directory. totally forgot. it's just easier.

    Edited 2 times, last by HackitZ: add a question, removed question ().

  • i have changed my yml file.
    Before i run the yml i'm going to search the folders on my main drive to see where all this data is that has filled my os drive.
    This is what i have run
    du -a /home | sort -n -r | head -n 25
    ok this command is not working. it's not showing anything about my os drive.


    Is there an easier way?

  • i have re installed omv, still not done.
    but when i run
    docker logs -f letsencrypt


    Server ready
    nginx: [alert] detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 f
    or OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html)
    nginx: [error] lua_load_resty_core failed to load the resty.core module from https://github.com/openresty/lua-resty-core; ensure you are using an OpenResty release from https://openr
    esty.org/en/download.html (rc: 2, reason: module 'resty.core' not found:
    no field package.preload['resty.core']
    no file './resty/core.lua'
    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua'
    no file '/usr/local/share/lua/5.1/resty/core.lua'
    no file '/usr/local/share/lua/5.1/resty/core/init.lua'
    no file '/usr/share/lua/5.1/resty/core.lua'
    no file '/usr/share/lua/5.1/resty/core/init.lua'
    no file '/usr/share/lua/common/resty/core.lua'
    no file '/usr/share/lua/common/resty/core/init.lua'
    no file './resty/core.so'
    no file '/usr/local/lib/lua/5.1/resty/core.so'
    no file '/usr/lib/lua/5.1/resty/core.so'
    no file '/usr/local/lib/lua/5.1/loadall.so'
    no file './resty.so'
    no file '/usr/local/lib/lua/5.1/resty.so'
    no file '/usr/lib/lua/5.1/resty.so'
    no file '/usr/local/lib/lua/5.1/loadall.so')

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!