Wake on Lan not supported with 5.2 Kernel?

  • I needed to update the kernel for a WIFI card that's coming this week and I wanted to be prepared.


    Wake on Lan doesn't work anymore though, before I was able to wake up my NAS from my router but now it doesn't work.


    Using OMV 5 it says WOL is activated on the current ethernet interface.


    Any ideas what I have to set up to get it working again?

  • Okay, reinstalled OMV 5 and updated to the 5.3 proxmox kernel.
    When I select standby from the top right OMV menu in the web gui it shuts the computer down.
    Tried pm-suspend from the command line but I get "command not found". I'm hesitant to install something from the CLI since I don't want to break OMV again. Is it save to install?

  • To check if it is supported, you can use: pm-is-supported --suspend and then actually suspend with systemctl suspend

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • When I enter pm-is-supported --suspend, nothing happens. I assume I should get any kind of output?
    systemctl suspend though suspends the system successfully and Waking it from Lan works too.
    Still when I select "standby" from the dropdown menu in the upper right it shuts the system right off.
    What's wrong here?


    Thanks for chiming in :)

  • When I enter pm-is-supported --suspend, nothing happens. I assume I should get any kind of output?

    Sorry for not mentioning more... echo $? after the command will show the answer. If 0, then your system supports suspend. If anything else, it doesn't support suspend.


    Still when I select "standby" from the dropdown menu in the upper right it shuts the system right off.
    What's wrong here?

    It looks like the code will try a suspend-hybrid first (if supported) then hibernate (if supported) then suspend (if supported). Otherwise, it does a shutdown.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry for not mentioning more... echo $? after the command will show the answer. If 0, then your system supports suspend. If anything else, it doesn't support suspend.

    It looks like the code will try a suspend-hybrid first (if supported) then hibernate (if supported) then suspend (if supported). Otherwise, it does a shutdown.

    thanks for clarifying, it's been a while with linux.
    So the output is "127".

  • The man pages don't have a good list of the exit codes. So, not sure what 127 means but I would interpret it as regular suspend is not supported.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • so how do I get it working then?

    No idea. I don't put my servers to sleep.


    Also pm-suspend works, but that's not what's getting triggered from the dropdown menu

    Need to figure out why systemctl suspend isn't working. @votdev

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • No idea. I don't put my servers to sleep.

    Need to figure out why systemctl suspend isn't working. @votdev


    systemctl suspend IS working! As well as pm-suspend. The computer shuts down, but keeps the LAN interface on, Wake on Lan works flawlessly this way. It's only the WEB GUI button "standby" that's not working

  • It's only the WEB GUI button "standby" that's not working

    The system must be incorrectly reporting that hybrid-suspend or hibernate are supported since those options are tried before suspend.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • What should I do then?

    Maybe try changing /etc/systemd/sleep.conf and disable the methods that don't work preventing OMV from using them? This describes the options - https://www.freedesktop.org/so…n/systemd-sleep.conf.html

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks for the tip!
    I thought the documentation was way too hard to understand for me as a linux noob, BUT I've found an exampe of a sleep.conf that seems to work (NAS goes to sleep when I press the standby button from the WEB GUI)


    Code
    [Sleep]
    # suspend=hybrid-sleep
    SuspendMode=suspend
    SuspendState=disk
    # hibernate=hybrid-sleep
    HibernateMode=suspend
    HibernateState=disk
  • I'm having this same issue. Is there a trick to get WOL working? I have tried removing my teamed nic and no matter what I do to try to wake it, it won;t wake. I noticed in the web admin page mine was not sleeping either. If I run systemctl suspend it sleeps like I expect it to. Waking is my only issue. Most of the time I will be sleeping with this command systemctl suspend


    It is not an internal nic it is an add on card. It use to work in v4 but now on v5 I'm having no luck.


    thanks


    looks like this is an issue, I have the same results After Upgrade to OMV 5.4.0-1 Wake on LAN does not work anymore, when putting System to sleep mode by autoshutdown plugin or manually

  • I'm having this same issue. Is there a trick to get WOL working? I have tried removing my teamed nic and no matter what I do to try to wake it, it won;t wake. I noticed in the web admin page mine was not sleeping either. If I run systemctl suspend it sleeps like I expect it to. Waking is my only issue. Most of the time I will be sleeping with this command systemctl suspend


    It is not an internal nic it is an add on card. It use to work in v4 but now on v5 I'm having no luck.

    Same issue. Putting the system to sleep (suspend) with systemctl suspend from command line works. Able to do WOL.

    Going to sleep from the web interface does not wake up the system

  • funny because I thought maybe it was a bios setting from things I was reading online but I don't think that is the issue on my setup. Reboot does the same thing. If I reboot from the command line using reboot it reboots normal. If I reboot in the GUI it stalls with wwatchdog time out.

  • You can chnage the WOL setting from omv-firstaid - have you tried that?

    Inwin MS04 case with 315 W PSU

    ASUS Prime H310i-Plus R2.0 board

    Four port PCI-E SATA card

    8GB Kingston DDR4

    Intel Pentium Coffee Lake G5400 CPU

    Samsung Evo M.2 256GB OS drive (28 GB partitioned for OS)

    4x4TB WD Red NAS drives - UnionFS pool

    Seagate 5TB USB drive - SnapRAID parity

    1x1TB Seagate HD

    1x300GB Toshiba HD

    Seagate 2TB USB drive

  • after my rebuild I assumed that the one main nic would be set to WOL but I noticed today I could not wake it and the NIC light was out. I checked with ethtool and it was disabled. It looks like you have to run the omv-firsaid when you setup any WOL in the interface. Hopefully this will be fixed in a later build.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!