After hard update the Raid 1 hdd shown as empty

  • That is very strange that it won't come out of read only. Can you mount it? mount /dev/md127 /mnt and see files in /mnt/?

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

    Edited once, last by ryecoaaron ().

  • Hello everyone,

    interesting thread, even for me who never used Raid actively (as I only use what I understand).

    If this is a Debian problem (OMV 2 based on Wheezy and OMV 4 based on Stretch) the solution could be post 2 and 10 (setup of ancient OMV 2). When Debian 9 and later cannot recognize the Raid setup by Debian 7 (what is very surprising for me), then any attemps under OMV 4 are doomed to fail.

    What about the following approach:

    I still have OMV 2.2.14 as a virtual machine under Virtual box, which I can send you via some kind of file transfer. Setup of OMV 2.2 in Virtual box, connect the drives raw passthrough to the virtual machine and repeat all steps from post 2 and later.

    This should also work on Debian 7 images, but if virtual machines are helpful, the old OMV 2 is more convenient.

    Any comments from the experts about virtual machines with Raid on physical disks?
    (I have tried Raid only once with virtual disks, it worked but I did not follow the Raid path)

    Second option, find someone in your area still using OMV 2 bare metall for rebuilding the Raid.
    As you also accept german language answers, I guess you are sitting in Germany or neighbour countries. OMV is realative widely present in Germany and people are lazy with upgrades when it runs.

    This could solve the issue - or exclude the option of having OMV 2/4 incompatiblities.

    But as at this stage the danger of doing something wrong by mistake which hinders later professional recovery, maybe in respect of the value of your data, it could be also an option to contact data rescue pros, to rebuild a broken Raid under Debian 7.


  • root@openmediavault:~# mount /dev/md127 /mnt

    Rem.: Shows no result

    When it mounts successfully, there is no output. What is the output of ls -al /mnt

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yes I'm from Germany but I don't know anybody who also use OMV. I don't want to go back in this moment because everybody they try help me here in this forum know about my system and I think when the versions switched to a different versions will confuse the people in here.

    I've been thinking about the Raid system this weekend and maybe I got a solution, so please let me know what you think about my idea.

    I install proxmox as server and OMV in a virtual machine with the two raid drives. Now I can do snapshots of the running OMV and test a newer version of OMV in a different VM with the same raid drives.

  • At which point are you now? Do you have access to your data or not?

    Just from a theoretical point of view: If the reason is incompatibility within Debian 7->8 or 8->9 as votdev mentioned, then you have to go back.

    Proxmox just adds one level of complexity, and I am not sure where the snapshots are stored to.
    And Proxmox does not give access to older systems.

    I would keep all as simply as possible.

    Of course Virtual Box also adds a level of complexity, therefore bare metal OMV 2 would be better, Or just a plain old Debian.
    But as I still have OMV 2.2.14 as VM available, it would be easy for you to set up.

    Nevertheless, as my knowledge about Virtual machines and Raids are very limited, before connecting your high valuable data disks to any foreign system, the opinion of rycoaaron, geaves, votdev, aso should be regarded.

    I wish you success with all attemps on OMV 4 and 5, and of course go on with this, but when this approach ends, I dont think that Proxmox would be helpful.

  • No access to the raid stored data.

    I just want to avoid the problems that I'm in right now. Proxmox seems to be a practical solution to me but maybe I'm wrong.

    In my mind there should be a raid1 system and one of the raid drives should be additionaly backed up. No idea how to create this but this will be a scenario I can live with.

  • Just for my curiosity, I set up OMV2 (in a virtual machine 2 cores, 4 Gig of RAM) with 'openmediavault_2.1_amd64.iso'. Went through until request for mirror servers.
    After some tries, I found out that the mirror on 'China /' still is active. I guess even some others more, but I did not tried every mirror in every corner of the world.

    The set up groused about not having access to '' but installation finally ended successfully. Was a matter of 10 minutes. Also Update Manager (Aktivierunsgverwaltung) was active and pushed OMV up to 2.2.14.

    Long story short: The last time you saw your data alive was on your OMV 2 before the hard update.
    Once again, in post 2 votdev recommended to reinstall OMV2 and here is the how to.
    That is the thing you haven't tried yet.

    The other question based on your initial post: Why did you think your system (OMV2) was corruted?
    No update anymore is a result of beeing out of service but not an indication of malfunction.

    Did you have any problems on your data access before you made the hard update to OMV 5?

  • I went a different direction. I installed omv 2.x and created a raid array. I then cloned the VM and install OMV 5.x fresh (not upgrades) from iso over the 2.x install. The array was auto-read-only. I then mounted it in the web interface and the array went to active and was completely normal. It had no problems after reboots.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Back on version 2.x and thanks to erik for the suggestion of the chinese mirror. I was running a little bit an earlier version of OMV 2, because it looks a little diffent than my former OMV but it's okay.

    No data were found on the raid (screenshot) and the drives were shown as empty.

    I'm stuck again right now.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!