Second user => no access

  • Hi.
    I'm just started with OMV on a Raspberry Pi4. Looks great!

    However, even after following all those configuration videos for multiple users step by step, I've got some problems with the permissions:

    Let's say, I set up two users: first: dh, second: sh.
    Then I set up a shared folder called "test".
    Then I set up the privileges for dh and sh on test to Read/Write.

    Then I set up SMB Share folder.

    As soon the yellow acknoledgement bar comes up, I always acknowledged (I didn't wait for all the changes and then did it only once at the end).

    So far so good.

    Testing the access on a Linux Mint, the first user (dh) works well. After changing the privileges for dh in OMV (e.g. to "no access") works well too and doesn't allow dh to see the folder in Linux Mint.
    However, despite having exactly the same privileges and settings for the second user (sh), sh is not able to access the folder (not even read!).
    Tested access for sh and dh via Android and Windows, same result.

    Any idea where the problem is?

    Kind regards,

  • Hi votdev.

    Thanks for your reply.
    I checked the ACL on my "test1" folder. There was no tick, neither at user "dh" nor at "sh", nor at any other system accounts. But "dh" still got access to the files, "sh" does not. I assume, that the privileges override the ACL.

    In another try I opened ACL for the test1 folder, ticked RW for "dh" and "sh". Didn't work. Still the same result (dh got access, sh not).

    Maybe it helps if I add the following fact: When I enter the credentials for sh in Win10, I can see at least the folder "test1", but I can't open it (no permission).

    Shoud I try a fresh install of OMV on the SD-card?

    Current System information:
    Version: 4.1.28-1 (arrakis)
    Processor: ARMv7 Processor rev 3 (v7l)
    Kernel: Linux 4.19.75-v7l+

  • Installed omv on the raspberry pi from scratch, did all the updates (to version 4.1.28-1).

    Still have the same problem: First user got access as expected, second user just see "test1", but is not allowed to open the folder.

    Any ideas?

  • Sad.

    Did some tests with deleting "dh", added a new user "dh2", but despite it is shown on first place in the list, "dh2" doesn't have access as well.

    Interestingly, if I add a second shared folder with same settings as "test1", neither "sh" nor "dh" got access.

    Seems to be a problem of handling lists?

    Checking other options than openmediavault now...

  • :thumbsup:

    Problem solved.
    I've used a pre-formatted (ext4) and LUKS-encrypted disk.

    There was no problem to mount the disk and create folders, however the permissions didn't work properly for the second user.

    Desperate as I was, I reformatted the disk with NTFS and no encryption.
    I reinstalled OMV, started from scratch and followed the guide on Tutorial in OMV forum.
    Now I had to "create" a disk in OMV, which formatted the disk with ext4 within OMV.

    Now the permissions are working correct.

    Maybe someone can explain to me, why it helped...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!