Easy Nextcloud Installation discussion

  • In addition to the two suggestions above there is a third option (at least). If you do not need smb for some specific reason, you can also bind mount your data to the container. Then you should be able to access these data with the external storage app without smb.

  • TechnoDadLife

    Hello TechnoDadLife,

    First of all, I would like to thank you for your great video, which made it easier for me to get started.

    I have installed the image on my old AMD computer and it is working so far.

    Unfortunately, I now have some problems getting important apps for Nextcloud to run.

    It is about

    * Onlyoffice


    * Full text search with OCR (Tesseract)

    It may be that there are restrictions in the image of Nextcloudpi that make it impossible to start / install the aforementioned apps. In my search, I only found that there should be difficulties between OnlyOffice and the web server related to Nextcloudpi.

    Maybe you have solutions to get the above apps up and running.

    Thanks in advance.


  • On the Nextcloud forums, there is a section where you can questions about NextcloudPi.

  • Thank you for this perfect Howto!
    I like to use "noip" for dns adress. But i have 3 hostnames in my account. I get an error, because nc dont know which adress he schould taken. Do you know a solution for me?

  • Hi there. I need help with instalation of nexcloudpi via docker, i cant get it work.

    After putting this commnand:

    docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v /srv/dev-disk-by-label-USB/appdata/nextcloud:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf

    the log stucked, and nothing hapens after 2 hours:

    If i restart the container, the log stucked on this, and nothing happens:

    Im trying to delete the container and image few times but the result is still the same.

    Im running on OMV5 with Rpi4. Can anyone get a hint?

  • Hi,

    My Nexctloud (nextcloudpi) on RPI2 works correctly since 10 days but sometimes I have this error on the web page:

    Internal Server Error
    The server encountered an internal error and was unable to complete your request.
    Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
    More details can be found in the server log.

    I need to STOP then START the container ro recover nextcloud and I don't know why. An idea ?



  • [SOLVED]: I re-installed the NextCloud installation completely according to TDL guides and got everything working nicely:)


    I am new to OMV but managed to install OMV 5 to NanoPi M4 v2. OMV works fine and using the instructions by TDL, I have installed Plex and Syncting which both work nicely. Then i tried NCP. Installation went smoothly, I was able to access NCP but got stuck with external access etc. and decided to power off the NAS since I ran out of time.

    I thought I would able to continue where I left since access to NCP worked then. Apparently I was wrong and currently unable to access NCP.

    NCP is running in Docker but with the following error messages:

    I have tried to solve this matter without success so far thus turning to this community for additional help.

    Any suggestions how to proceed?

  • I decide to install nextcloudpi I ran into a first error saying 443 was used so I changed on the general page of OMV 443 by 453

    the second error is maybe because my docker storage is /srv/dev-disk-by-label-WD_10TB_1/docker

    docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v /srv/dev-disk-by-label-WD_10TB_1/AppData/ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf
    WARNING: Error loading config file: /root/.docker/config.json: read /root/.docker/config.json: is a directory

    so anyway I can get to the page NexcloudPi Activation no problem there, but I am unable to go to https://nextcloudpi.local:4443/ or so I cannot continue the config!

    in the log I am also getting The current PHP memory limit is below the recommended value of 512MB.

    So How to correct those errors?

  • Like I said I do not have any issue to land on nextcloudPi Activation page using either


    but I cannot reach https://nextcloudpi.local or https://nextcloudpi.local:4443

    the latest error message is

    -1 }">2020-05-30 4:41:39 0 [Note] mysqld (mysqld 10.3.22-MariaDB-0+deb10u1) starting as process 226 ...
    -1 }">
    Starting Cron
    -1 }">
    Starting Postfix
    -1 }">
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)
  • I do not use nextcloudpi, but the MySQL error sounds strange. Do you have another container with MySQL running? Have you been asked at some point, if you want to use an external database or an internal one?

    If you need an additional MySQL container, both container must be on the same docker network.

  • I deleted the container rename ncdata old recreated everything with but got an error

    WARNING: Error loading config file: /root/.docker/config.json: read /root/.docker/config.json: is a directory

    docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v /srv/dev-disk-by-label-WD_10TB_1/AppData/ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf
    WARNING: Error loading config file: /root/.docker/config.json: read /root/.docker/config.json: is a directory

    Anyway is running but sill

    I cannot reach https://nextcloudpi.local or https://nextcloudpi.local:4443

  • So far so good but I got stuck with ports I want to change the ports this way

    docker run -d -p 4443:4443 -p 460:443 -p 85:80 -v /srv/dev-disk-by-label-WD_10TB_1/AppData/ncdata:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf

    but I cannot access the nexcloud pages, and I think it has to do with apache2 but not sure how to modify those?



    <VirtualHost _default_:80>
    DocumentRoot /var/www/nextcloud
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
  • Well I hope somebody can give me a hint. I am still using docker letsencrypt on port 450 and 90 according to a video from TechnoDadLife for my other app emby; jellyffin ;OMV; Airsonic.

    I really want to try using this nexcloud pi on this ports because I don't think I can get a different certificate on 433 just for nextcloudpi without messing up the other app, and I cannot afford to loose the outside connection from all those other app witch are working good.

    Maybe is it possible to configure nextcloudpi without the built in external access and just modifying a letsencrypt/nginx/proxyconf ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!