Problems installing Pi-hole in Docker

  • Hi everyone and a Happy New Year,


    I am trying to install Pi-hole in Docker. I had been following this video tutorial:



    But I stumbled across this error message when I saved the image setup:





    The entire text in the box is:




    I did everything I saw in the tutorial except coping and pasting the same commands in the extra arguments box.
    I mean, it seems that there is no -p command in version 3.0.
    https://hub.docker.com/r/pihole/pihole
    Could you please tell me what I got wrong?
    Thanks

  • is your system amd64 type? or perhaps are a raspi?


    other settings that maybe erroneus are:


    IPv6="True" <- Really do you need IPv6??



    ServerIP="0.0.0.0" <- This must be the IP assigned on mac-vlan <- Do you create a mac-vlan?

  • I'm running OMV on VMware Workstation. My real machine is an amd64.
    I created a macvalan in docker->networks as I saw in the videotutorial.
    as for the IPv6, I did nothing about it. It was there already. Do I need to set it as "False"?


    Anyway, I did everything from scratch, and it works now. I can log in pihole dashboard, but if I change my old static IP with the new one (the serverIP one) in my DD-WRT router I lose internet connection. I don't know what is wrong with it now. The strange thing is that I can see the "Total queries (2clients)" number on to the top left of pihole's dashoboard increasing although I can't browse anything.
    I then tried to set pihole IP local address in the ethernet IPv4 properties (first server DNS) and it works.
    Any thoughts about that?
    Thanks

  • I'm running OMV on VMware Workstation. My real machine is an amd64.
    I created a macvalan in docker->networks as I saw in the videotutorial.
    as for the IPv6, I did nothing about it. It was there already. Do I need to set it as "False"?

    If it works, it works, don't change without good cause.


    Anyway, I did everything from scratch, and it works now. I can log in pihole dashboard, but if I change my old static IP with the new one (the serverIP one) in my DD-WRT router I lose internet connection. I don't know what is wrong with it now. The strange thing is that I can see the "Total queries (2clients)" number on to the top left of pihole's dashoboard increasing although I can't browse anything.

    I don't understand what exactly you did.

    I then tried to set pihole IP local address in the ethernet IPv4 properties (first server DNS) and it works.


    Any thoughts about that?

    This is how it should be, just put that same IP address in all entries so nothing can bypass the Pi-Hole.

  • DNS1 must be the IP of your PIHOLE, and DNS2 must be your DNS provider (eg: 1.1.1.1 or 8.8.8.8 to use google).



    use of DNS1= your pihole DNS is explain in the pihole docker documentation. = 127.0.0.1 in the documentation

  • DNS1 must be the IP of your PIHOLE, and DNS2 must be your DNS provider (eg: 1.1.1.1 or 8.8.8.8 to use google).



    use of DNS1= your pihole DNS is explain in the pihole docker documentation. = 127.0.0.1 in the documentation

    Sorry, But I don't think I've understood.


    this is a screenshot of my DD-wrt router:


    What exactly should I insert in static DNS1, 2 and 3?
    My pihole Ip is 192.168.3.66.
    Thank you

  • DNS1 and DNS2 are variables in pihole docker to instruct pihole what DNS servers do you want to use, please read pihole readme.



    You only need to configure Static DNS 1 in your router if your router is your DHCP server, only in that case need to configure it with your pihole DNS, so your DHCP server can instruct to your devices what IP, must have, what default gateway and what DNS server to use.

  • DNS1 and DNS2 are variables in pihole docker to instruct pihole what DNS servers do you want to use, please read pihole readme.



    You only need to configure Static DNS 1 in your router if your router is your DHCP server, only in that case need to configure it with your pihole DNS, so your DHCP server can instruct to your devices what IP, must have, what default gateway and what DNS server to use.

    I set dns1 and dns2 in my dd-wrt router. It worked but the page loading was incredibly slow. I think I'll stick with the manual method, that is, setting DNS on each single device.
    Thank you

  • please post a screen capture on your Static DNS 1 & 2 config on dd-wrt router.


    as i say you only need to configure Static DNS 1, and only if your router is your DHCP server.

  • please post a screen capture on your Static DNS 1 & 2 config on dd-wrt router.


    as i say you only need to configure Static DNS 1, and only if your router is your DHCP server.

    I did it already. I posted a screen capture above. I just set 192.168.3.66 (pihole Ip) in Static DNS1, and 1.1.1.1 in Static DNS 2. That's all.
    Yes, my router is my DHCP server, although in cascade to my ISP router.
    Thanks

  • Deleite static dns 2 to use pihole.

    I did it too already. I told you about that earlier.
    Pihole seems to be working by itself (the amount of Total queries and queries blocked increase as webpages are loading, but I can't see anything in the browser. I got this, for example:


  • You need to configure DNS INSIDE the pihole ( DNS1=Your docker IP) DNS2= 1.1.1.1 for example.


    pihole must work to resolve DNS.


    before you delete Static DNS 2 on your router, DNS works sometimes ( and slow), because you hava a secondary DNS resolver in your Router, but this is NOT what you want if install pihole.



    Please read about how pihole works.

  • I believe you need to have piHole’s ip in DNS1 and NOTHING in DNS2. Leave it blank.

    RAID is NOT a backup and not useful for most home users. Rsync makes true backup and restoration stupid easy, and it's built right in to OMV. Use this command in a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-NAMEofSOURCEdisk/ /srv/dev-disk-by-label-NAMEofDESTINATIONdisk/

    Hardware: OMV 5 (current) - NanoPi M4: Nextcloud, Plex, & Heimdall - Acer Aspire T180: backup - Odroid XU4: Pi-Hole (DietPi) - Odroid HC2, Raspberry Pi 3B+, and HP dx2400: testing.

  • I fixed it.
    I unchecked the "Forced DNS Redirection" box in my DD-WRT router. Pihole works now as a static dns in my router setting, and my browser can load webpages.
    Anyway, I haven't yet understood why this setting doesn't let my browser load webpages if pihole (DNS) IP is set in my router.
    Thanks

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!