Failure while configuring zfsutils-linux after update to 4.19.0-0.bpo.6-amd64

  • Hi omv community
    I ran into a problem while updating my OMV machine.
    It seems like zfsutils-linux and zfs-zed won't update.'

    The output from apt -f install :

    Output from systemctl status zfs-mount.service:

    and journalctl -xe:

    I am running the normal Debian Kernel (no Proxmox).
    Is there a way in which I can easily fix this?
    Any help would be greatly appreciated!

    Many Thanks

  • So I got it fixed myself and will leave here what worked for me in case other people run into this issue.
    ***If this is not wanted by the admins you can remove this thread***

    To fix it I unmounted all zfs filesystems using zfs unmount -f [zfsmount] and temporarily removed the mountpoints so the point where the pool should be mounted is completely empty.
    After that it was possible for me to run the update using apt -f install. Then you only need to recreate the mountpoints and mount the zfs filesystems. I had some problems with mounting the filesystem afterwards but this was gone after a restart.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!