Serviio Install Guide

  • I just want to ask. when serviio will appears in plugins? Thanks.


    Right now I haven't made any plans to turn it into a plugin. It may be something I'll do in the future but not anytime soon. Plus I have another plugin I need to finish. I have been very busy personally so I apologize for the late reply. You can also install Serviio by using the Docker plugin and searching for Serviio. I have tested it on my dev machine and it works as well. There is a little extra setup to do but I haven't had time to write up a guide for it. I'll be glad to answer any other questions you have.

  • The guide has been updated to support Serviio 1.6 on OMV 2.x. Please note I have not tested it on OMV 3.x beta so feel free to try it at your own risk. I do plan to release an initial plugin for testing on OMV 3.x so stay tuned. Thank you all for your support on this project. I will continue to maintain Serviio for OMV. There is also the option to use Serviio through the Docker plugin if your interested. Thanks again! :thumbsup:

  • Thanks a lot shadowzero that you consider to build an OMV-plugin for OMV 3.x. This would be really helpful especially for the newbies among us.

    OpenMediaVault 5.x (most recent stable version) -- 64 bit -- OMV-Extras 5.x (most recent stable version) -- Default Kernel

  • I've upgraded to Serviio 1.6.1 and discovered that it won't work properly with libav. It seems ffmpeg was introduced back into Debian last year so I've installed that and Serviio works as it should.

  • The ffmpeg package for wheezy used a depreciated version. It works but at the time writing the guide libav was being pushed to use instead so that is why this guide uses libav for OMV 2.x. The good news is I have tested 1.6.1 on OMV 3.0.13 beta with ffmpeg and it works just fine. I am working on developing a plugin for OMV 3.x but for now if you want to test on OMV 3.x, use ffmpeg instead of libav.

  • I am having trouble installing serviio on a fresh reinstall of OMV. I keep getting "insserv: Script serviio is broken: incomplete LSB comment." After about 5 hours searching the internet and trying everything, I am flustered because I can not get it to work. I've checked for misplaced tabs, taken out all the spaces and retyped, Nothing works. Suggestions appreciated.

  • Hi @Cwj,


    Sorry for the late reply. I tested the guide on OMV 2.2.5 and I did not have a problem with the init script. I would suggest removing the one you have in place. As root, run update-rc.d -f serviio remove and delete the file rm /etc/init.d/serviio Go back to step 4 and copy the init script again and do step 5. That should fix your issue. If it doesn't, let me know and I'll continue to work with you to fix it. :thumbsup: One good thing did come out of testing, some of the commands in the guide did not execute correctly but were minor. If I do them manually it worked just fine. You gave me a good reason to check it and to go back and update the guide. Thank you for that.

  • hi everyone.


    i just tried to install serviio on my OMV sys. but first i wanted to install java. so i started with point 6 of this tutorial, but the installation failed because my 1st HDD / USD drive is full now (just a 2 GB stick). the installation stopped and now i get an errow because the system drive is full.


    how can i manually remove the java installation / folder?


    i even can not login via webinterface from local network :-/


    i can login via putty as root.


    thanks in advance, guys.


    greetz


    mcpaschetnik

  • SOLVED Ok now works, after I build FFMPEG but you can also use this to get ffmpeg:

    Code
    wget https://johnvansickle.com/ffmpeg/builds/ffmpeg-git-64bit-static.tar.xz
    tar xf ffmpeg-git-64bit-static.tar.xz
    mv ffmpeg-git-20161223-64bit-static/ /usr/bin/ffmpeg-git-20161223-64bit-static
    ln -s /usr/bin/ffmpeg-git-20161223-64bit-static/./ffmpeg /usr/bin/ffmpeg


    Build version:


    Have anyone issues to start serviio 1.8? 1.7 is working. 1.8 doesnt the log says:


    Code
    root@omvt20:~# service serviio restart
    Shutting Down Serviio Media Server...:.
    Starting Serviio Media Server...:.
    root@omvt20:~# grep ERROR serviio.log
    2016-12-21 11:00:21,616 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: FFMPEG not found. Serviio will not work properly.
    root@omvt20:~# service serviio status
    Serviio is currently offline.:
    root@omvt20:~#


    So FFMPEG is missing, but Serviio Install Guide says "Please note: Serviio will complain that FFmpeg is not installed in the logs but that is OK since we use Libav instead of the depreciated FFmpeg package.".


    i just tried to install serviio on my OMV sys. but first i wanted to install java. so i started with point 6 of this tutorial, but the installation failed because my 1st HDD / USD drive is full now (just a 2 GB stick). the installation stopped and now i get an errow because the system drive is full.


    how can i manually remove the java installation / folder?

    tried? apt-get remove oracle-java8-installer

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!