OMV-Server ist nicht mehr über Netzwerk erreichbar - Netzwerkinterface geschossen?

  • Hallo liebe OMV-Gemeinde,
    ersteinmal entschuldigung, dass ich diesen Post auf deutsch schreibe. Ich habe, glaub ich, einen ziemlichen Bock geschossen! Ich bin ziemlicher Anfänger was OMV angeht und habe mir OMV5 auf einem Odroid HC2 mit einer 16 GB SD und einer 4TB HDD installiert. Ich habe mir ein paar Benutzer eingerichtet und meine ganze Video-Sammlung auf die Festplatte gezogen. Das System lief die ganze Zeit einwandfrei und problemlos. Nun wollte ich zusätzlich zu OMV noch Pihole auf den Odroiden installiern. Ich hab mich im Netz nach Anleitungen umgesehen, und bin dabei auf omv-firstaid gestoßen. Damit kann man wohl die Netzwerkeinstellungen von OMV ändern (wenn man Pihole auf dem gleichen System installiert hat, gibt es anscheinend öfters Probleme mit den WebGUIs - diese kann man dann anscheinend mit hilfe von omv-firstaid beheben). Wie dem auch sei, ich habe mal über Putty omv-firstaid gestartet und gleich mal den Menüpunkt 1 "Configure network interface" ausgewählt (Jugend forscht X/ ). Da ich jedoch nichts verändern wollte, habe ich bei den folgenden drei Fragen immer "No" ausgewählt. Dann kam die Meldung (den genauen Wortlaut bekomme ich leider nicht mehr hin), dass das Netzwerkinterface neu eingerichtet wird und ich soll warten. Nach fünf Minuten hat sich noch immer nichts getan, und in meiner Naivität hab ich mir gedacht, da ich ja sowieso keine Änderungen durchgeführt habe, ziehe ich einfach mal die Stromversorgung ab und starte den Odroid HC2 neu. Tja, und das war's: der HC2 fährt anscheinend normal hoch (blaue LED zeigt Heartbeat an, HDD läuft an, grüne LED bei Netzwerkbuchse blinkt unregelmäßig), wird aber in der Fritzbox im Netz nicht angezeigt und mit Angry IP Scanner auch nicht gefunden. Meine Vermutung ist nun, dass ich wohl das Netzwerkinterface zerschossen habe. Nun meine Frage: wie bekomme ich das Gerät wieder zum Laufen? Gibt es irgendeine Möglichkeit noch auf den Odroid zuzugreifen? Ich habe jetzt so das ungute Gefühl, dass ich wohl um eine Neuinstalltion nicht herum komme <X Aber wie Installiere ich OMV neu, ohne die Daten auf der HDD zu verlieren?

  • Hallo,


    1 - Du wirst Deine Daten nicht verlieren!
    Wenn Du die Platte (HDD) ausbaust, kannst Du sie a) an einen Linux-PC hängen, b) an einen PC mit einer Life-CD (oder Life-USB) von Linux hängen, z.B. Knoppix oder c't desinfect, c) unter Windows mit Programmen auslesen, die EXT4 (vermutlich bei Dir im Einsatz) oder andere Dateisysteme auch unter Windows anzeigen. a) und b) sind zu bevorzugen, c) ist suboptimal.


    2 - Solltest Du OMV neu installieren (am besten mit ausgebauter HDD) und anschließend die HDD wieder anschließen, kannst Du ganz normal auf die Daten zugreifen. Also Freigabe einrichten. Sofern die namensgleich mit der alten Freigabe ist, wirst Du auch darin die Daten wiederfinden.


    Tip am Rande: Sollte Deine Sprache mit der Zeitzone korrelieren, würde ich heute nacht nichts mehr machen. Der einzige weitere mögliche Bock ist eine überhastete Neuinstallation mit eingebauter HDD und fälschlicher Anwahl dieser HDD als Installationsort. Dann sind die Daten wirklich weg, bzw. nur noch schwierig bis lediglich forensisch wiederherzustellen. Morgen früh ist noch alles da.


    Nichtsdestotrotz: Backup ist immer wichtig!


    3 - Der korrekte Weg wäre es gewesen, den Port 80 in der OMV GUI (Webinterface) auf einen anderen Wert zu stellen. Ich habe einen xu4 (gleiche Platine wie der HC2, nur andere Peripherie) und darauf laufen simultan OMV4, pihole und ioBroker.


    4 - Der Fehler ist wahrscheinlich leicht behebbar. Hätte der HC2 einen Monitorausgang könnte man Tastatur und Monitor anschließen und direkt darauf zugreifen. So musst Du die /etc/network/interfaces auf der mSD-Karte woanders konfigurieren. Also die mSD Karte an einem anderen Linuxrechner einbinden und dort editieren (und am besten vorher einmal komplett kopieren).


    Ich denke, andere werden noch genauer beschreiben was einzustellen ist, bin selber nicht so fit.
    Sollte die nächsten Tage nichts kommen, kann ich auch mal schauen was bei mir in dieser Datei steht, in der Hoffnung, dass zwischen OMV4 und OMV5 nicht zuviel Unterschiede sind. Das Problem dürfte sein, das richtige network interface zu beschreiben. Montag treffe ich einen Freund, der auch einen HC2 mit OMV5 besitzt. Dann kann ich da mal nachschauen.


    Gruß
    Erik

  • Ich konnte das Problem in einer virtuellem Maschine mit OMV5 nachstellen.
    Nachdem ich den Netzwerkadapter abgeschossen hatte, reichte es aus, /etc/network/interfaces.bak nach /etc/network/interfaces umzubennen. Nach einem 'reboot' war der Server wieder mit Putty erreichbar.


    Das heißt für Dich, die mSD rausnehmen und an einem Linuxrechner einbinden und dort entsprechend editieren.


    Falls das nicht funktioniert, bei meinem xu4 (OMV4) steht in der /etc/network/interfaces:




    Alles mit '#' am Anfang sind nur Kommentare. Die letzten beiden Zeilen betreffen ip6 sind sind wahrscheinlich auch nicht notwendig.
    Die Netzwerkangabe (enx.....) muss auf jeden Fall stimmen (also zu Deinem HC2 passen), sonst geht das ins Leere.


    Ob das unter Windows einzubinden und zu editieren geht, weiß ich nicht. Solltest Du mit einem Treiber für ext4 zugreifen, dann einen Editor nehmen, der Linux-konform ist, z.B. Notepad2.


    Noch ein Tip am Rande: wenn alles wieder läuft, auf der Kommandozeile den Midnight Commander mit 'apt-get install mc' installieren. Den kann man später gut gebrauchen.


    Viel Erfolg!

  • So, leider brachte das Umbennen der interfaces.bak in interfaces nichts: die Datei war leer. Leider konnte ich auch mit dem von Erik geposteten Dateiinhalt der interfaces Datei nichts anfangen, da ich anscheinend eine andere iface Bezeichnung habe. ABER: Ich konnte die Daten der HDD auf meinem Win PC sichern (mit Paragon Linux File Systems for Windows). Ich hab jetzt mein System kplt. neu aufgesetzt und die Daten zurückgespielt! Vielen Dank noch einmal für die Hilfe :thumbsup:
    LG Jörg

  • Hab heute abend auf einen originalen HC2 mit OMV5 geschaut. in der Tat sind interfaces.bak und interfaces ziemlich leer, die Netzwerkinfos stehen woanders.
    Würde mich auch interessieren, wo die landen.
    Allerdings wird diese Datei wohl ausgelesen, wenn was drin steht, dazu muss aber die (hardwarespezifische) Angabe vom network interface stimmen.


    Na egal, Hauptsache alle Daten sind jetzt wieder da, wo sie hingehören und nichts verloren.
    Gruß
    Erik

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!