I'm receiving constant emails with Connection failed nginx followed by Connection succeeded nginx some 30 secs latter

  • This comes in the email


    Description: failed protocol test [HTTP] at [127.0.0.1]:443 [TCP/IP TLS] -- HTTP: Error receiving data -- Connection timed out


    or sometimes this


    Description: failed protocol test [HTTP] at [127.0.0.1]:80 [TCP/IP] -- HTTP: Error receiving data -- Resource temporarily unavailable


    This is the syslog (I edited my emails out):
    monitoring.png


    Any idea what could it be?

  • Monit is monitoring if the webserver is available and sends an alertion email if not. Seems your system has some issues with nginx because the email is only send after monit has realised issues multiple times in a time range.

    I started tinkering with notifications settings trying to disable this notification then noticed watching netdata that my cpu usage sometimes went 100% and the culprit was "email" in the applications tab so I disabled notifications for a while.


    I remember my first update was made using apt-get update/upgrade instead of omv-update, then a blueish screen for email appeared but I didn't set the email there, I waited and used the WebUI, maybe some wrong config is exposing a bug, is there a way to fix that?

  • Monit is monitoring if the webserver is available and sends an alertion email if not. Seems your system has some issues with nginx because the email is only send after monit has realised issues multiple times in a time range.

    Hello again Volker,


    Would low entropy cause nginx to stall? Or would a nginx cause entropy to fall? I just received one of these email and then I went straight to netdata to check any difference and noticed that the lowest point in entropy chart was the moment I got the email. Some minutes before that I was SSHing to OMV. Still, the lowest was about 1000, so I'm not sure if this is related to anything.


    That being said, yesterday my internet was offline and I noticed nginx kept restarting in syslog, attempting to reach out 127.0.0.1:443, so I imagined there was a problem with my self signed SSL I disabled HTTPS webui and stopped receiving emails every hour or so (the one I mentioned above is the first one of the day).


    entropy.png

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!