Error after latest update to 5.2.3-2 "The data model 'conf.service.mergerfsfolders.folder' does not exist."

  • Hi,


    OMV 5 was running well and I just installed the update that was under "Update Management". It is now running 5.2.3-2(Usul) however I am now getting the error stated in the subject "The data model 'conf.service.mergerfsfolders.folder' does not exist." It pops up randomly or when I select certain options.


    The drives are all appearing in Storage - Disks but if I click on Storage - File System I get the error and no file systems are listed. Same thing if I click on Shared folder. Under the Snapraid tab i see all my setup.


    What is strange is that my merged drives are still accessible via the network so everything seems to be ok on that front. Portainer also still running. Content of the drives is also available via the terminal session so all is being well mounted. I am guessing the config file must have gotten corrupted somehow.


    The detailed error message I am getting is:


    Error #0:
    OMV\Exception: The data model 'conf.service.mergerfsfolders.folder' does not exist. in /usr/share/php/openmediavault/datamodel/manager.inc:149
    Stack trace:
    #0 /usr/share/php/openmediavault/config/database.inc(68): OMV\DataModel\Manager->getModel('conf.service.me...')
    #1 /usr/share/php/openmediavault/system/filesystem/backend/unionabstract.inc(64): OMV\Config\Database->get('conf.service.me...')
    #2 /usr/share/php/openmediavault/system/filesystem/backend/manager.inc(280): OMV\System\Filesystem\Backend\UnionAbstract->enumerate()
    #3 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(821): OMV\System\Filesystem\Backend\Manager->enumerate()
    #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(71): OMV\System\Filesystem\Filesystem::getFilesystems()
    #5 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->enumerateFilesystems(NULL, Array)
    #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #7 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(322): OMV\Rpc\ServiceAbstract->callMethod('enumerateFilesy...', NULL, Array)
    #8 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getList(Array, Array)
    #9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
    #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatuscK...', '/tmp/bgoutputvk...')
    #12 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #13 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(471): OMV\Rpc\ServiceAbstract->callMethodBg('getList', Array, Array)
    #14 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getListBg(Array, Array)
    #15 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #16 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getListBg', Array, Array)
    #17 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getListBg', Array, Array, 1)


    #18 {main}



    Any help would be appreciated as I do not want to reinstall everything. Thanks

  • There is a new plugin called mergerfsfolder see if you can install maybe can push the error away. Keep posted here how it goes. This is probably a bug the union fs backend.

    Thanks. That did the trick. Should I use to mergerfsfolder plugin going forward instead of the union filesystems?

  • I was using the mergerfs addon and combing drives. After the update I loaded the unionfs addon prior to reading this thread to try and resolve the error. As per the other user comments above this appeared to resolve the reported error. I then decided to remove the existing mergerfs addon as I wasn't using it. This repeated the error but it was now reporting about a unionfs config issue. I then resinstalled the mergerfs addon and the error went away (yes, I know I've gone down the dumb road with multiple install/uninstalls and not keeping notes and testing inbetween steps).
    I did observe that the folders I was sharing all seemed to be intact and where I expected them to be.
    Only after all of the above did I try and access the 'file systems' tab on the web gui. There are no entries in the file system web page and I small popup showing a 'loading' message.
    I don't know when in the above process this occurred.
    ie if it was as a result of my install/uninstall effort or as a result of the unionfs addon install with an existing mergerfs configuration.

  • Shit. Having the mergerfsfolder and union filesystems plugins installed would fix this but I will have to change the backend.

    omv 5.5.13 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!