Slow SMB network transfer write speeds

  • Hi I'm new to the omv platform. I'm running omv 5 and been having this issue where the transfer speed would start out fast like saturate a 1gb network connection then just go to 0 then will smooth itself out to about 30mb/s. Now this is not good for me because I keep a loot of big files on this NAS because I run plex on one of my other servers so most files are over 2gb and can be as big as 60gb for 4k movies. I don't really know linux too much so any suggestions would have to be explain. I'm not aiming for 100mb/s but would like to be around 80mb/s. I have also attach an image of what I'm talking about. Also SMB 1 is removed in windows 10. also too mention I also had this problem on omv 4.

  • There are many similar threads here. Perhaps you can find hints there.

    Common causes:

    Slow router/switch.
    No switch.
    Slow USB interface.
    WiFi is used.
    NTFS is used on the NAS.
    Slow and feeble Windows client.
    Bad cables.
    Network extensions using power lines.
    Bad network configuration.
    Slow drives.
    Slow network interface.
    Small NAS overloaded with multiple tasks/transfers.

    You can run test on the network and the drives to check the nominal speeds. But even if that gives good results combination of minor problems using marginal equipment might slow things down.

    Google "test network speed" or "test disk speed" for instructions on how to test your setup. Or search similar threads here.

    It is unclear what the chart shows. But it seems to first buffer the transfers at full speed. Then when the buffers are full the transfer speed drops significantly. This suggests to me that your network is OK but you have a problem with very slow disk performance. USB and/or NTFS being used.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited once, last by Adoby ().

  • I have a similar issue:

    Complete 1 Gbit LAN - NAS, Clients .. Direct to Router (MK4011)

    SSD connected via USB3.0 (EXT4)

    SSD disk (benchmark 3500/3300 MB/s) - while copy CPU load 0-1%

    When copying big (in most cases multiple files) the speed is constant around 117 MB/s for some time, after a short time it starts to fall down a lot down until it stops. When looking at NAS load, the CPU load climbs to 100%. After eg. 1 minute, copying resumes at full speed.

    I didn't see this on OMV4.

  • I have some vague memory about changes in Debian how UASP drivers for USB drives did or didn't work as expected. And how Debian did or didn't blacklist some SATA/USB interfaces.

    So in OMV 4 (fast) UASP drivers sometimes wasn't used but instead only the ordinary (slower) USB3 drivers. In OMV 5 the (faster) UASP drivers are always(?) used but sometimes don't work correctly. Resulting in extremely slow USB transfer speeds. Much slower than ordinary USB3 without UASP.

    The workaround is to manually blacklist incompatible SATA / USB interfaces from using the fast UASP drivers. Or to make sure you don't use/buy USB drives without first making sure they support using UASP drivers in Linux.

    I bought some USB enclosures recently. Before that I checked for this VERY carefully and I ended up only buying Startech USB 3 enclosures. 2.5", 3.5" and dual 3.5". I assume other brands might work fine as well. I have been very happy with the performance of my Startech enclosures. They all work at full UASP speeds. "USB3 turbo."

    When you check, make sure it says that the USB drive/enclosure is compatible with Linux or at least is compatible with ANY operating system. Otherwise it may or may not work properly.

    If it says that it is compatible with Windows and Mac, it might only be compatible with Windows and Mac.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Try to disable the UASP driver with the enclosure and see if that helps. The enclosure might be usable in Linux without the UAS drivers?

    The enclosure might be compatible with Linux, but perhaps not with the UASP drivers. Perhaps even MUCH slower with the USP drivers than without.

    Try some other enclosure.

    Your description seem to confirm that it is the interface that is very slow. Not the network and not the drive in itself. Fast transfer until buffers are full. Then the very slow interface throttle the rest of the transfer.

    Can't find anything matching "router MK4011". What is that?

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • There seem to be many models of the RB4011 router. It seem to have several GbE ports but it doesn't say anything about any switching capacity. It is possible that it works fine as a switch. It is possible that it doesn't. it is possible that it is just intended to work as a router, not a switch. IDK.

    I am very skeptical to "combo" routers. But that is just my personal experience that talks...

    I have a separate router, a separate WiFi mesh and a separate GbE switch.

    I would recommend buying a dedicated GbE switch and use that for the LAN, and then connect the switch to the router.

    I doubt it will help performance much. But who knows?

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Hi guys

    I have the same issues that my transfer speed with smb are only between 10 mb/s and 20.

    Now I want to find the reason.

    I went trough the initial points from Adoby and here is the result:

    Slow router/switch. --> Fritzbox 7590
    No switch. --> No switch
    Slow USB interface.
    WiFi is used. --> Yes
    NTFS is used on the NAS. --> No, ext4
    Slow and feeble Windows client. --> Dell XPS 15 9570, I think no
    Bad cables. --> cable is a Cat 6e and tried with different cables
    Network extensions using power lines. --> no power lines in use
    Bad network configuration. --> what is a bad network configuration? Examples?
    Slow drives. --> Seagate Ironwolf
    Slow network interface. --> Killer 1550 with speed up to 1733 mbit/s ( in fritzbox I see the speed is in the most time over 1000mbit/s)
    Small NAS overloaded with multiple tasks/transfers. --> ASRock J5005-ITX CPU is in average at 20-40% and RAM (16 gb) is enough free, no multiple transfers in same time
    OMV5 on Debian, NAS is over 1 Gbit LAN directly at the fritzbox 7590.

    Do you have more ideas?

    My samba configurations in omv are as following:
    socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    read raw = yes
    write raw = yes
    max xmit = 65535
    dead time = 15
    min receivefile size = 16384
    write cache size = 524288
    getwd cache = yes
    max connections = 65535
    max open files = 65535
    min protocol = smb3
    max protocol = smb3

  • I checked the speed with iperf and i get the same result.
    So I think there is a problem with the network configuration? or maybe the ethernet driver on the J5005-ITX Board?

    I have an r8169 modul but the firmware from r8168.
    Others are not available at

    Can this be the reason?

    I am grateful for any advice.

    PS: I run OMV 5.2.4-1 on top of Debian GNU/Linux, with Linux 5.4.0-0.bpo.2-amd64.

  • I think it is the FritzBox. Slow router/switch. My top suspect?

    Try to borrow a real GbE switch from someone and try it to see if that helps.

    But, by all means, try with a different NIC as well.

    If it is Debian 10 having problems with the right driver I assume you should find something about that if you search the net.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Okay i bought a Netgear GS308E and will test this tomorrow.

    I have done a test with my laptop connected via lan to the FritzBox and via iperf the result for a 1000M file are 600 MBits/sec. Upload via SMB is between 50-100 Mb/s.
    Can I exclude with the results there is something wrong with the NIC? like the drivers?

    I have already read that r8168 had problems with the driver of r8169. But not vice versa.

    I cannot understand why i get a so bad result via laptop wifi - i have a Killer 1550 Wifi Card with speed up to 1733 mbit/s! In the fritzbox gui I see also the speed is in the most time over 1000mbit/s...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!