Does OMV, Autoshutdown-Plugin or Debian change WOL-Settings of interface?

  • Hello everybody,


    I have a problem with the WOL settings of my interface. Beside the method of waking up the server by a magic packet, I want the server to resume from suspend mode when the SMB/CIFS-share
    is triggered from another client (for example Windows 10) (should be a unicast message).


    Currently I'm at the position, that this is working when I manually suspend the server via shell with "pm-suspend".


    But when the server turns into suspend mode by the Autoshutdown-Plugin, I'm not able to resume from the suspend mode by triggering from client share access.
    Then I only can wake up the server with a magic packet (for example send via Fritzbox).


    What I have done so far:


    1.) Edit /etc/network/interface




    Here you can see that I added/change to post-down/post-up with wol mode ug.


    2.) Added shutdown-Script: /usr/lib/pm-utils/sleep.d/70wol

    Bash
    #!/bin/bash
    ethtool -s eno1 wol ug


    I'm not quite sure if both or only one of them leads the way to wake up the server after the "pm-suspend" command manually entered in the shell and triggered by Windows Client to wake uo, but it works.


    3.) Here is the /etc/autoshutdown.conf




    Nothing yery special- Only checking some ports and ULDL-Rate.




    What I found out so far:


    After manually suspended the server and woke it up again, "ethtool eno1" shows me the info I suspect

    But after I wake up the server with magic packet after suspended by Autoshutdown-Plugin, the "ethtool eno1" shows me that only wol mode "g" is set?!?


    So the it seems, that OMV, the Autoshutdown-Plugin and/or Debian "overwrites" my settings in /etc/network/interface and/or /usr/lib/pm-utils/sleep.d/70wol.


    Is it possible? Does someone has a clue for me which shutdown-/suspend-script could be responsible for this?


    Thanks in advance


    Greetings


    Michael

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!