Having trouble transferring files to my NAS

  • So I wanted a NAS. Thought building my own with a Raspberry Pi was a cool little project and learning experience. Had a few minor hiccups because I had little prior experience with Linux and no prior experience with the Pi. Got everything working eventually after searching this forum and Google. Thanks to everybody posting tutorials, guides and helping others.


    Raspberry Pi 4b
    OMV 5.2.2-1
    Connected via Ethernet
    External HDD (EXT4) connected to my Pi via USB3


    MiniDLNA, SMB, FTP all work.
    Streaming media files to my Android and Windows devices works just fine.


    However I can't solve the problem of copying my media library to the NAS. The first couple of dozen files transferred fine from my laptop to the NAS, then the transfer suddenly stopped until Windows gave me an error message that the device was not responsive. The Pi couldn't be accessed through the OMV web interface or through Putty at this point, until I restarted it. I repeated this a few times and transferred more files over, but the transfer was aborted at some point every time.
    Googled the problem and found threads that described similar problems, suggesting that this could be solved by using FTP instead.
    So I switched to transferring the files from my desktop machine via FTP instead of SMB. At first I got constant speeds of 110MB/s, until the transfer was interrupted after a few dozen files too.
    The error message my FTP client gave me was this:



    Quote

    Copying files to remote side failed. Transfer aborted. Interrupted system call.

    Which... doesn't really tell me anything to be honest.
    I also found threads describing similar issues caused by the Pi's ethernet controller and I tested transferring files via Wifi, which didn't help either, I couldn't even transfer a single 2Gb file before the same error occurred.


    Any suggestions on what else I can try to fix this?

  • A very common problem is power for the external USB HDD.


    It is not at all certain that the RPi4 can supply enough power to the external HDD, if it doesn't have a separate powersupply.


    Typically a USB stick or a SSD may work OK. Sometimes even an unpowered 2.5" HDD. But not always.


    Another common problem is heat. With the original firmware the RPi4 had tendencies to overheat. A good enclosure with a fan or other heat transfer is recommended. Also updating the RPi4 firmware.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks for the suggestions. The HDD is a WD MyBook with its own power supply, not relying on the Pi to power it.
    When I ordered the Pi, I ordered a heatsink along with it. It's a passive aluminum heatsink covering both sides of the board. The Pi does get warm to the touch though, which did concern me a bit. Will check the firmware.


    /e
    Turns out the firmware was already up to date.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!