OMV4 - no information about updates in WebGui available

  • Hello,
    my OMV system sends regularly informations about new available updates to my set up email adress. So far thats working perfect. But since a while, I can't see any of the propagated updates in my web gui. If I do a check in the system update Gui there's nothing showing up.
    So I wonder if something is misconfigured in the process, and why this happens. Before, I was shown the relevant updates in this web gui and could activate/trigger them from there.


    Actual example and screenshots attached (i.e. information which I got by email...).


    Any ideas, experiences about this behaviour? Thanks a lot in advance!

  • Most likely your OMV NAS is no longer connected to the internet.


    Check your network and router. Can you access the internet from elsewhere in the LAN? Have you changed something in the network? Gateway/Router?


    You can also login to the OMV NAS using SSH and try to ping some site on the internet. For instance google.com.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • And what was the result when you ran apt-get update?


    As far as I know the GUI update is just and apt-get update. Same with upgrade.


    Perhaps you have everything updated and upgraded using apt-get recently?

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Well, if you can't see anything to update using apt-get update, then you won't see it in the GUI either.


    Could it be possible that your system is fully up to date? When was the last time you ran an update & upgrade?


    You could try to install something, to verify that apt works as normal.


    Do you have mc (Midnight Commander) installed? Great shell file manager. Also works fine over SSH. Handles fish, SSH and ftp. And much more.


    sudo apt install mc

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Thanks, I know mc (even not so familiar by its components...).


    I've rechecked my received system-infos again - one update from the jan-14th just downloaded the data in "download only" mode (see scrnshot) and another one, from jan-15th actually stated the update process itself (scrnshot).


    In my opinion, thats little bit strange, I expected the system to do nothing with the first downloaded data (from the 14th) since it said "in download only" mode . But - even without my interaction - on the 15th those update data were really processed. Didn't expect this to be done automatically !


    So, may be everathing is updated and system is in good state. (?)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!