Cannot connect to shared folder (SMB/CIFS)

  • Hello everyone. I am having a hard time with OMV since 2 days straight now.

    I followed the installation and setup instructions very carefully.
    I have setup the simplest scenario possible:

    OMV is running on a raspi 4b, setup according to the latest instructions from here:…ing_OMV5_on_an%20R-PI.pdf
    I took these steps:

    1. Mount the hdd drive
    2. Create a shared folder on that drive with read/write/execute for everyone
    3. Enable SMB/CIFS
    4. Create a share referencing the before created shared folder
    5. Set the share to "Only guests"

    What happens is, the shared folder shows up in my Windows 10 network tab of the explorer. But when i try to enter it, i get "You have no permission to access..."

    I tried to set the share to "Guests allowed", create a user with PW etc, but then i also can't connect to the shared folder.

    I also tried to connect tot the shared folder from Ubuntu, same here..

    Also, i set up a NFS share, on which i also could not connect from my ubuntu machine, although it was visible..

    I really don't know what could be wrong with this easiest of all setups. I would apreciate any tips...

  • For open access, SMB should be set to "Guests Allowed".

    Take a look at this -> post and check your Windows 10 network Settings.

    If you're trying to create permissioned access (assuming you're using a local Win10 account):
    Create a user in OMV, that matches the username and password exactly, that you're using to log into the Windows 10 client.

  • Thank you crashtest for your reply.

    I went through the steps provided in the pdf.
    - I set my network-settings on the windows client accordingly.
    - I doublechecked the workgroup name - it was already matching on both, windows-client and omv
    - I set the LmCompatibilityLevel to 5
    - I tried to enable SMB2 but the provided commands for the powershell resulted in errors...(Yes i very carefully copied/pasted the commands)
    - I edited the windows 10 host file according to the instructions.

    Also i followed your advice to set the share to "Guests Allowed"

    None of these measures made any difference. I still can't connect.

    Any further advice?

  • What edition of Windows 10 are you using? Is it, by chance Enterprise or the Education edition? (If so, there's a section on this toward the end of the How-To document. Those editions assume they'll be connected to a domain by default, so they require a security policy change.)

    Also, you could try setting LM compatibility to 3.

    Double check the "Shared Folder" permissions access. Go to Access Rights Management, Shared Folders, click on (highlight) your shared folder, then click the ACL button. Others should be set to Read/Write . Others set to "Read/Write" goes with SMB set to "Guests Allowed".


    Also, setting up the User + password in OMV, Access Rights Management, Users is another possibility to remove a potential permissions blockade. (Assuming something else is going on.)
    Again, create a user in OMV that exactly matches the user name and password that you use to log into the client, that is trying to access the server. The user name and password must be an exact match, capitalization and all, of the username and password on the client.
    (The creation of this user, in OMV's GUI, will add it to OMV's "users" group by default. Shared folders set access to the group "users" by default as well.)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!