urbackup client-server issue - raspberry pi 4b

  • Greetings,
    Issue:
    unable to have the client seen the server and the server to see the client.


    Info:
    both are in same subnet
    I have installed urbackup via portainer.
    Since I had issues with the backup target path (keep having errors like path not existing.. but it does), I have removed the docker image and reinstalled from different developer.
    Also used the stack image (currently running the stack image).
    In all cases beside the very first time, I am unable to have the client seen the Server. But also the server seen the client.
    Server says Client not online!
    When the first time I installed it and the server saw the client, I had to abort the backup as the backup storage location was wrong! I needed to have it stored in a main folder where all the shared folders are so: /sharedfolders/backupPC
    Since URbackup did not like it and kept giving errors (non existing folder error), I tried the absolute path. Same issue.
    So I removed that image and tried others.
    Ever since, the 2 elements (server-client) do not see each others.
    I have tried to install the client in other laptops, I have the same issue.
    I would love some help! :D


    Regards
    kattivius

  • is your container running the network=host variable?


    Also could you post the stack you are using?

    Hi Morlan,
    at the moment I use your stack. (I did follow your suggestion from the other post to use the uroni one. but since did not work well, I came back to yours as it did seem to work on the very first run).
    I only changed the backup path location:
    =====
    version: '2'



    services:
    urbackup:
    image: morlan/urbackup_docker:latest
    container_name: urbackup
    restart: unless-stopped
    environment:
    - PUID=1000 # Enter the UID of the user who should own the files here
    - PGID=100 # Enter the GID of the user who should own the files here
    - TZ=Europe/Berlin # Enter your timezone
    volumes:
    - /path/to/your/database/folder:/var/urbackup
    - /path/to/your/backup/folder:/sharedfolders/backupPC
    # Uncomment the next line if you want to bind-mount the www-folder
    #- /path/to/wwwfolder:/usr/share/urbackup
    network_mode: "host"
    # Activate the following two lines for BTRFS support
    #cap_add:
    # - SYS_ADMIN
    =====

  • is your container running the network=host variable?


    Also could you post the stack you are using?


    This is interesting...
    I did not specify any configuration when creating the stack.
    If I am looking at the right spot, looks like no network is defined at all!
    Looking at the container details, I saw the 'connected network' empty!
    Am I manually supposed to choose a network?


    (see snapshot)

    Also noticed here that the path to my backup folder is dorrectly defined but the volume right under it gives the wrong name: /backup
    (or I believe is wrong as I defined a different path for the backup folder)

  • Just an idea, not a recommendation:
    Urbackup is easy to install on Debian.
    It is the only application I installed on Debian. I never tried to install it in Docker. All others are in Docker.

    Its an idea.
    But I would like to keep it within OMV as I will have more to run.
    Maybe you mean installing urbackup outside OMV in the same box?
    it could be an idea but I rather keep things within OMV that is the only thing running in my RPi.
    I though, since there are docker images for it, should be working fine.
    Lets see....

  • Maybe the urbackup log file may help? Don't know the location for the docker version but by defalault it is /var/log


    Edit: Oh, I forget... if it's Win clients it may be a good idea to disable the firewall to test (and in case add the client to the rules)

    it is supposed to have the exception already (last I checked).
    Tomorrow I will try to take the win. firewall off all together for a test.
    PS
    just tested it. Disabled it... but still no communication between the 2.

  • The configs of the image changed since I gave you the stack to be more aligned with the original docker image. Sorry for the confusion the image was WIP at that point.
    Try this new stack:


  • The configs of the image changed since I gave you the stack to be more aligned with the original docker image. Sorry for the confusion the image was WIP at that point.
    Try this new stack:


    Later on today I try it.
    FYI:
    the stack source code I copied here was from the dockerhub. (https://hub.docker.com/r/morlan/urbackup_docker).
    This you suggest is back to uroni. Dont you prefer I use yours?

  • The configs of the image changed since I gave you the stack to be more aligned with the original docker image. Sorry for the confusion the image was WIP at that point.
    Try this new stack:


    Morlan,
    that script gives an error:

    maybe because of the uroni/urbackup-server-multiarch:latest?


    I think you mentioned once that should be something else. possible?

  • Yes sorry! I forgot to delete the -multiarch. I did in a previous draft of the post :|


  • Yes sorry! I forgot to delete the -multiarch. I did in a previous draft of the post :|



    do I have to modify the path to database folder?
    I did not modify anything database path. If I live it as is, will it get the correct path?
    If not, where is it in OMV?
    thanks

  • You have to specify a path which is valid on your system. If you are running OMV from a SD-Card you should choose a folder on your harddrive to reduce wrintings on the SD-Card. For example put in the folder where your other docker config folders are located.

  • Yes sorry! I forgot to delete the -multiarch. I did in a previous draft of the post :|



    do I have to modify the path to database folder?
    I did not modify anything database path. If I live it as is, will it get the correct path?
    If not, where is it in OMV?
    thanks

    You have to specify a path which is valid on your system. If you are running OMV from a SD-Card you should choose a folder on your harddrive to reduce wrintings on the SD-Card. For example put in the folder where your other docker config folders are located.

    OK.
    UPDATE:
    it seems that my mistake was to accept the PUID and PGID
    By default:
    PUID: 1000
    PGID: 100
    turns out both have to be 1000 (thats for me)


    I also change the backup path to the absolute path o my /srv/dev-disk-by-label-DATA/backupPC shared folder.
    I did not modify the path to the DB (here a question at the end of the update [1])
    communication and back are now successful. :thumbsup:


    Strange:
    the backup is successful and I can see it from the logs. HOWEVER... when I open the shared folder in windows, it is empty.
    When I look at the shared folder in WinSCP, the folder is empty.
    When I check with putty using absolute path, the files ARE there!
    If I check the shared folder using the SMB shared path, the folder is EMPTY
    Should all those path point to same location?
    Absolute path and SMB path are the same folder at the end, correct?


    =====
    [1]
    in relation to the DB path, since I defined all dockers images to be under a docker folder that is located in my 1T external SSD, doesn't the urbackup DB also be stored in the docker image folder?
    Or it would still write it externally on the SD Card?
    =====
    regards

  • Don't use the /sharedfolders/ path in Docker. Always use /srv/dev-disk-by-label.xxxx/yyyy
    EDIT: ok, you mentioned, that you tried the absolute path as well ;-)

    @macom
    actually you are correct.
    Now that I have connection between client and server, I noticed that if i use the SMB shared path, it simply does not work.
    When using the absolute path, it does .
    /srv/dev-disk-by-label.xxxx/yyyy


    but I cannot see any file in the SMB share.

  • I must say, I am having quite some hard times make urbackup to work properly.
    I am adding a new client and now I receive storage space issue.
    as I point to /srv/dev-disk-by-label.xxxx/yyyy and that is a new 1T SSD, there are no space issues.
    HOWEVER, I have the feeling that I am not setting something right...
    the following is the Stack script that is modify and changed the database and storage location to the shared folder.:
    ===
    version: '2'
    services:
    urbackup:
    image: uroni/urbackup-server:latest
    container_name: urbackup
    restart: unless-stopped
    environment:
    - PUID=1000 # Enter the UID of the user who should own the files here
    - PGID=1000 # Enter the GID of the user who should own the files here
    - TZ=Europe/Berlin # Enter your timezone
    volumes:
    - /path/to/your/database/folder:/srv/dev-disk-by-label-DATA/urbackup-db
    - /path/to/your/backup/folder:/srv/dev-disk-by-label-DATA/backupPC
    # Uncomment the next line if you want to bind-mount the www-folder
    #- /path/to/wwwfolder:/usr/share/urbackup
    network_mode: "host"
    # Activate the following two lines for BTRFS support
    #cap_add:
    # - SYS_ADMIN
    ===
    In portainer --> Container --> inspect, I see few lines I am not sure are correct:


    "Mounts":
    [ { "Destination": "/srv/dev-disk-by-label-DATA/urbackup-db", "Mode": "", "Propagation": "rprivate", "RW": true, "Source": "/path/to/your/database/folder", "Type": "bind" },
    ===
    in the above, source seems a vage destination.moreover:
    ===
    { "Destination":
    "/backups", "Driver": "local", "Mode": "", "Name": "b259e5d9b915b242e5659ad728561947dc9956d39407e830f9630951cd107d96", "Propagation": "", "RW": true, "Source": "/srv/dev-disk-by-label-DATA/dockers/volumes/b259e5d9b915b242e5659ad728561947dc9956d39407e830f9630951cd107d96/_data", "Type": "volume" },
    ===
    here I notice that the destination is /backupsI have manually changed that also in the server. A little after this part of the script, the correct folder is named!
    What is really happening?
    where did I miss to point out the correct storage folder?
    Look forward some suggestions...
    kattivius
    PS
    Apologies for formatting.. I tried to fix it manually. for some reason, the copy and paste was unformatting the code.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!