Pihole, macvlan - cannot reached site

  • Hello,
    I had a working pi-hole. But suddenly it stopped functioning. I have reinstalled, configured the network, but cannot open the pi-hole configuration page. In the docker logs, pihole starts correctly. I also noticed that when I change anything in the settings of the OMV network card (Network >> Interfaces) I lose connection to OMV and it returns after restarting the Raspberry Pi with the settings I changed. The address 192.168.1.245 does not respond, does not ping, the page does not open. Help me please.


    My conf:
    OMV 4 192.168.1.2
    Pihole 192.168.1.245
    MacVlan Parent eth0, 192.168.1.0/24
    Dev Raspberry Pi 4, OMV

    Files

    • 1.PNG

      (13.13 kB, downloaded 77 times, last: )
    • 2.PNG

      (3.24 kB, downloaded 46 times, last: )
    • 3.PNG

      (27.08 kB, downloaded 72 times, last: )
    • 4.PNG

      (41.46 kB, downloaded 66 times, last: )
    • 5.PNG

      (30.42 kB, downloaded 56 times, last: )
    • 6.PNG

      (13.71 kB, downloaded 77 times, last: )
    • ifconfig.txt

      (4.06 kB, downloaded 13 times, last: )
  • I see it ... but I installed the docker pihole again

    Well that how to is still good to use. I just followed the how to as far as the macvlan and I apologise it does add brackets.


    But with regard to your second set of images that macvlan is pointing to the container name as in your first image, whereas your second image the container name is set to pihole

  • and yes, I'm sorry, I didn't press refresh. Still no connection. Is it possible that something is wrong with the configuration of the network card or the reason is that it is rpi4? The most interesting thing that it worked fine for many months, was probably an upgrade of the pihole docker. But, I install from begin...

  • On my router I have disable dhcp service. Only have dhcp service on OMV (screen), last ip address 192.168.1.240


    On my previous conf I have full range 192.168.1.0/24 dhcp, and 192.168.1.200.


    I have the impression that OMV has a communication problem with the network card. The same if I try to change something with web OMV in the network adapter settings then I lose connectivity and I have to restart RPI.
    I added my pihole container log.

  • On my router I have disable dhcp service. Only have dhcp service on OMV (screen), last ip address 192.168.1.240

    Why? If it's to ensure that Pi-Hole is used for DNS that's fine, but your IP range only really needs to be from .3 to .30 for home use + the DNS Search Domains needs to be empty, in DNS Servers you could add your routers IP address until pi hole is working.

  • So,
    1) DNS Search Domains - When pihole worked properly in this place i have pihole dns address (192.168.1.200 previous)
    2) My router (netgear) haven't option to set dns address to clients, this setting is constantly set to itself (192.168.1.1)



    Quote from geaves

    ange only really needs to be from .3 to .30 for home use


    You have right, but it does not matter. this address (245) is out of range


    Now pihole doesn't answer on any ip address....192.168.1.200, 192.168.1.245...and i haven't more ideas why

  • One thing that is relevant when you reinstall i.e. stop the container the delete it, delete the image and delete the macvlan you should also ensure that the pi-hole config folder is removed as well.


    So you're saying that putting in http://192.168.1.245/admin into a browser you cannot connect after the specified 2/3 mins.

  • One thing that is relevant when you reinstall i.e. stop the container the delete it, delete the image and delete the macvlan you should also ensure that the pi-hole config folder is removed as well.


    So you're saying that putting in http://192.168.1.245/admin into a browser you cannot connect after the specified 2/3 mins.

    yes,exactly...after 2,20,1hr...
    and as you can see the log contains:
    (...)
    DNSMasq binding to default interface: eth0
    Added ENV to php:
    "PHP_ERROR_LOG" => "/var/log/lighttpd/error.log",
    "ServerIP" => "192.168.1.245",
    "VIRTUAL_HOST" => "192.168.1.245",
    (...)
    and
    [✓] DNS service is running
    [✓] Pi-hole blocking is Enabled
    [cont-init.d] 20-start.sh: exited 0.
    [cont-init.d] done.
    [services.d] starting services
    Starting pihole-FTL (no-daemon) as root
    Starting crond
    Starting lighttpd

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!