Clean start of NextcloudPi docker fails on /var/run/redis/

  • Hi,

    I'm trying to start a Nextcloudpi docker and it always fails with the message:

    Starting redis-server: start-stop-daemon: matching on world-writable pidfile /var/run/redis/ is insecurefailedtried chown the file inside the docker with 700, 750 with no success, always same message... (probably I'm being a big noob here... sorry)How can I solve this?Thank you in advance


    • log.txt

      (2.92 kB, downloaded 126 times, last: )
  • Didn't saw that specific topic. searched quite a bit for similar issues with what I had but not with much success. Specially on this specific image.

    I deleted the "ncdata" folder from my AppData folder and deleted the nextcloudpi image from docker then pulled everything again. And on the log it says that it is making a clean install.
    I simply followed your Youtube guide. First time it worked fast and smooth. It only failed now after I moved docker from one disk to another... all containers are fine with this exception, even after deleting everything and remaking.
    I though that with this image, everything was already made together inside one container? Or is there something else I should delete outside docker/container?

  • 192 (network adapter in "bridge" mode)

    172 I think is the internal ip within docker platform?

    De server "kind of started"...
    De user+passwords appeared and after clicking to continue the setup process it became like this:

    (192.xx.xx.xx:4443 isn't working)

  • "Solved"

    Since it seems to me to be some kind of issue inside the docker folder... and I don't understand how to solve it...

    Did a backup from all containers setup commands.
    Removed docker
    Removed docker folder
    Made new docker folder
    Instaled docker
    downloaded all images again
    remade macvlan (pihole)
    remade all containers through command line to be faster than using Portainer interface
    all configs seem to be ok since I kept AppData folder
    made new ncfolder
    started new NextCloudPi
    Woking again now... Finally!
    SMB through NC working, letsencrypt, etc...
    Now, time to remake users, groups, etc, for all family members

    Thank you TechnoDadLife for the help.
    Looking forward for your next youtube videos :)

  • Total newbie here. I followed TechnoDadLifes video and it failed at the same time.

    It cant start the redis server.

    I removed docker, all appdata folders, reinstalled docker, tried running the container again but it stills gives me the same error.

    I have no clue what to do now. Any help is appreciated.


  • Can you provide a log of the container? To see where it fails for you exactly?



    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • This is a nextcloud pi problem. You should be contacting them about this. It is a problem they need to fix.

    I am releasing a new and even easier nextcloud install video today. That should help.

    Build, Learn, Create.

    How to Videos for OMV

    Post any questions to the forum, so others can benefit from your curiosity. :thumbsup:
    No private support.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!